After struggling a tiny bit with render durations on some low-lit Cycles scenes, I am trying to convert a Cycles render scene to a Blender internal scene and hopefully, get faster rendering times.

After switching the project to Blender Internal Render, I converted the neon lights that spell the word on the wall, by deleting the material and creating a new material. I increased the Emit value since the neon letters should illuminate the whole scene. And enabled Indirect Lighting in World panel, as well as set Gather to Approximate.

The result is somewhat strange:

enter image description here

1-There are strange artifacts around the emitting objects

2-The letters do not illuminate the scene as they used to in Cycles, unless the objects are mirror/reflection enabled (the bed and the hand are very dark)

3-the glow coming from the light objects only carries onto a small strip of the neighboring walls, which then become dark abruptly, instead of bathing the room in an ambient glow

This is the scene in Cycles, and what I would like the scene to look like (note how the whole room is filled with light yet the glow is soft and casts shadows):

enter image description here

I have looked online and here on SE for render engine conversion tips but couldn't find any...

Blend file:


1 Answer 1


I did some changes to your scene. The strange artefacts result from the high emit value and the curves themselves.

  1. I adjusted emit value to 15 instead of 1000.
  2. Give the curves some extrusion. No neon light is total flat, it has some depth. A value of 0.001 works great.
  3. I added some ambient occlusion. A value of 0.008 makes the scene less dark but preserves the night mood...

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .