2
$\begingroup$

Using cycles on AWS G2-8X large which has 4 GPUs however cannot get blender to use more than 1 GPU at a time even though I can get it to switch between GPUs any suggestions? I have the latest drivers and versions

$\endgroup$
2
$\begingroup$

I know this question is pretty old but posting this in case anyone is having similar issues.

The question is a bit vague. I'm assuming you're using python script to call and render something in blender. I'm also assuming that you're using the following lines in the python script for setting GPU as the render device:

bpy.context.scene.cycles.device = 'GPU'
bpy.context.user_preferences.system.compute_device_type = 'CUDA'
bpy.context.user_preferences.system.compute_device = 'CUDA_0'

where the CUDA_0 means to use the first graphics card, CUDA_1 for second graphics card and so on. To make use of all the graphics cards, all you have to do is to modify the third line to:

bpy.context.user_preferences.system.compute_device = 'CUDA_MULTI_0'

Unrelated: If you want to see what all options are available for this setting in your current system, use the following in the python script:

print (bpy.context.user_preferences.system.bl_rna.properties['compute_device'].enum_items.keys())

Please note that if you give only this line in the script, it will show only 'CPU'. Make sure you set the render device to GPU using the code sample I've shared, and then use this line.

$\endgroup$
0
$\begingroup$

I believe it depends on how you are sending the rendering to the farm. This must be done via a script IIRC. Renderbot may have a setting to accommodate this as well.

Dalai's post illustrates the issue: https://www.dalaifelinto.com/?p=746

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.