1
$\begingroup$

I am running FreeBSD 10.2 64 bit with fvwm-crystal. In all other cases, just starting a program from an xterm opens a window with buttons. Blender does not open in a window with buttons, which in itself is not a problem. However, when I try to set user preferences, the new window does not have buttons, and I can not close the User Preferences window. I tried "dbus-launch blender" but no difference. I do not see any configuration options for recompiling blender that might make any difference. Any advice would be appreciated. Thanks.

$\endgroup$
  • $\begingroup$ Are you asking how to access blender's preferences without encountering this issue? Or how to get the wm to put buttons on blender? $\endgroup$ – gandalf3 Feb 2 '16 at 3:20
  • $\begingroup$ Do you get the title bar of the window so you can drag it around? Blender should get a normal window with standard close/resize widgets the same as any other program, the same when a new window is created for preferences. I use xfce and can use Alt-F4 to close a window (that's a window manager setting), also right clicking on the title bar of the window gives a menu with a close option. This would be window manager related, you would do better trying fvwm support options, or maybe emailing the freebsd-questions list or forums.freebsd.org $\endgroup$ – sambler Feb 2 '16 at 10:23
  • $\begingroup$ @gandalf3 I would certainly be satisfied with being able to access user preferences without encountering this issue. Although I am curious about why fvwm-crystal is not putting buttons on blender, I sense that that question may be difficult to answer. $\endgroup$ – Frank Greco Feb 2 '16 at 16:06
  • $\begingroup$ @sambler There is no title bar from the window manager. The top of the window contains the names of the sections: Interface, Editing, etc. Using fvwm-crystal's command to close the User Preference window causes Blender to quit. I will certainly look to freebsd or fvwm lists for help if there is no solution within Blender. $\endgroup$ – Frank Greco Feb 2 '16 at 16:16
  • $\begingroup$ I hadn't looked at the cli options for a while - blender has -w to force opening with window borders (default) and -W to force without window borders. $\endgroup$ – sambler Feb 3 '16 at 13:05
1
$\begingroup$

You can open the preferences inside the existing blender window by setting the editor type in the header of any existing area:

enter image description here

As for why blender isn't getting a titlebar from the wm, I have no idea. It works fine for me here on openbox.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.