0
$\begingroup$

Can anyone tell me what I'm doing wrong here? I'm attaching the file. Why are my materials not assigning to the eye? I have one for the inner eye mesh called "eyeball" and one for the outer eye mesh called "outereye".

Also, when you open the file, you will see a logo on the character's body. I followed the tutorial, which told me to use an empty, but the result is supposed to be one logo on his chest. As you can see, the logo is repeating all over his body.

EDIT: Actually I see the logo in the center now when I render. Is it possible to see it in center without having to render?

https://drive.google.com/open?id=0B85i1BKJ9r96Z0NCM3RoNFVpZzQ

Thanks

$\endgroup$
  • $\begingroup$ see this link: blender.stackexchange.com/questions/516/… $\endgroup$ – cegaton Jan 31 '16 at 19:05
  • $\begingroup$ Already did that and it doesn't work. Or maybe it is assigning it but there's something wrong with the material itself? It looks like an eyeball on the preview and just like in the tutorial but I'm not seeing it on the mesh. $\endgroup$ – SRCP Jan 31 '16 at 19:13
2
$\begingroup$

The material is assigned to the faces of the eyes, but the coordinates for the texture are wrong.

Set them to UV...enter image description here

The other eye is a mess too... it needs to be UV unwrapped.

enter image description here

$\endgroup$
  • $\begingroup$ when I did this for the first time, I didn't have to do that. The book says to use "Generated mapping". I don't know if that was because the eyes were in different layers and I then moved them to the same layer as the rest of the body? (Had to, to move the head with them) When I do what you do, the texture looks bad in the preview, but seemed to render fine. Why? I also can't see it on the model until I render. As for the other eye, why do I get that diagonal line for UVs? When I press E I don't get anything else. $\endgroup$ – SRCP Feb 1 '16 at 17:16
  • $\begingroup$ The UV unwrapping for both eyes is different. $\endgroup$ – cegaton Feb 1 '16 at 17:52
  • $\begingroup$ How do I fix the UVs? All I've done so far in this book apart from creating seams for the head is unwrap using E and it's worked. $\endgroup$ – SRCP Feb 1 '16 at 18:32
  • $\begingroup$ Look for tutorials on UV unwrapping. If you have further questions please ask them in separate posts. $\endgroup$ – cegaton Feb 1 '16 at 18:41
  • $\begingroup$ I fixed it. Someone helped me in a different forum. I got a good idea about the UVs now. But the material preview still looks bad, before all this it looked just like an eyeball. And I can't see the material on the model either unless I render, where it does look perfect. What's causing this? $\endgroup$ – SRCP Feb 1 '16 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.