4
$\begingroup$

I'll reproduce my question below, but for an extended description including example screenshots, please consider visiting this reddit post I've made on the same topic. Thanks for your time,

Unticking "Volume Scatter" in an emissive object's Cycles Settings (Object Properties) doesn't appear to produce the intended result.

For the result I'm seeking, I need lights which are placed close to my subject, often in the camera frustum. For these I disable "camera" ray visibility in the aforementioned cycles properties, so only the light they emit is visible in the final render.

However, any time I set up a scene like that, I can't use "world" volume scattering, because these lights are participating in the volume scattering process, and the resulting effect is nonsensical.

There is no hookup in the Light Path shader input node to query if a ray is checking against volume, so I'm stumped. Can I get what I'm looking for through some other setting or compositing trick?

Many thanks,

$\endgroup$
3
$\begingroup$

Ahh, it seems with Lamps it works just fine. Apparently emissive meshes can't opt out of volume scattering right now, but lamps can.

Perhaps this'll help someone in the future

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.