2
$\begingroup$

In blender cycles the world emits light, so the preview shows the objects illuminated by the world light but when I bake the texture ends up black, how do I enable this world light to be in the bake?

$\endgroup$
  • $\begingroup$ related: blender.stackexchange.com/questions/28491/… $\endgroup$ – cegaton Jan 30 '16 at 1:59
  • $\begingroup$ I am new to blender, it's difficult to understand how to do this using the link in your comment, can you explain the steps to enable the world light in the bake? $\endgroup$ – porente Jan 30 '16 at 2:26
1
$\begingroup$

Second edit, I finally found the cause of the problem, I have in blender 2 objects, one is engulfing the other this engulfer is a tube with a weird shape, the thing was that I had this tube as "restrict from viewport visivility", in the "preview" the tube was not affecting the rendered image but in the "bake" it was, can this be considered a bug?

$\endgroup$
0
$\begingroup$

You can disallow this tube from rendering by going to properties - object tab - cycles setting and turn off camera. Hope this helps

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.