1
$\begingroup$

I am having an issue where the vertex that I have selected does not highlight connected edges. This happened sometime when I was modelling and it is starting to annoy me. Following this link, It says that un-checking the edge under mesh display would make the highlight disappear. I checked it and its still checked.

enter image description here

Loading a new file seems to display the edge highlighting and this leads to the assumption that I might have accidentally hit another shortcut that caused the edge to not highlight.

enter image description here

How can I fix this issue?

$\endgroup$
  • $\begingroup$ Just to make sure, if you select everything do any of the edges highlight? Or is it just for that vertex? I just want to make sure that it's not just because you accidentally duplicated that vertex so it isn't connected to anything or something like that. $\endgroup$ – TARDIS Maker Jan 28 '16 at 19:00
  • $\begingroup$ @TARDISMaker Selecting any other vertex results in the same issue. I have used remove doubles to remove any duplicates and the problem is not resolved. Selecting 2 edges will highlight the edge between but none other. $\endgroup$ – DarkDestry Jan 28 '16 at 19:01
  • $\begingroup$ Are there any modifiers on mesh ? $\endgroup$ – Mr Zak Jan 28 '16 at 20:23
  • $\begingroup$ @MrZak Mirror and Edge Split $\endgroup$ – DarkDestry Jan 28 '16 at 20:29
  • $\begingroup$ @MrZak No, But the Mirror modifier has it on. Turning it off fixes it. Thanks. Create an answer below and ill accept it. $\endgroup$ – DarkDestry Jan 28 '16 at 20:47
2
$\begingroup$

In this case the vertice wasn't highlighted as expected because the Mirror modifier, which was present in stack, had button Adjust Edit cage to modifier's result turned on.

enter image description here

This means the result of modifier's work was visible while in Edit mode and editable more or less (so you could select verts mirrored by it, for example).

But in this case part of mesh doesn't exist (because result isn't applied yet) and hence existing vertices of the mesh aren't highlighted as usual (when edges which are connected by these vertices are highlighted too) rather than one by one. Edge is being highlighted only when 2 vertices were selected.

GIF showing verts with option turned on / off

Note: vertices' size is increased for demonstration purposes.

To work without this behaviour uncheck Adjust Edit cage to modifier's result in order to directly interact only with real vertices of the mesh. You can check it if needed to preview changes when it's important for the workflow.

Read more about interface of modifiers and meaning of the present buttons.

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.