2
$\begingroup$

I am using Blender 2.69 from the Linux Mint Software Manager on a system with a GTX 950, just checking to see if it will recognize CUDA. After some work, I've gotten the CUDA drivers from Nvidia installed and now there is an option to use CUDA as the compute device in the user preferences. I also selected GPU compute in the properties panel. I rendered a short, one minute clip of video using Cycles Render and monitored my GPU usage in Nvidia X Server settings. It didn't seem like the GPU was being used much (hovering 5-10%) but the video did render a little quicker than I expected.

How can I know for sure if Blender is using my GPU to the fullest to render?

$\endgroup$

closed as off-topic by David Feb 26 '16 at 20:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is too localized in its current form and is unlikely to be applicable outside of a very narrow context. Consider broadening the scope of this question in order to make it more useful for future users of the site." – David
If this question can be reworded to fit the rules in the help center, please edit the question.

1
$\begingroup$

If you have properly set up CUDA and selected GPU Compute in the Render Properties panel then Blender should be using your GPU. (Though I have seen instances where having two different Blender files open separately and both rendering switches the GPU one to CPU mid-render.)

Probably the easiest way to make sure that Blender is utilizing your GPU is to use some sort of monitoring program.

My Favorite is NZXT CAM, it's pretty sleek and works very well. CAM monitors and gives graphs of CPU and GPU load, temperature, voltage draws, and fan speeds. It also shows which programs are using the most load.

HW Monitor is another very popular choice, it doesn't have all the options that CAM has though. It basically just shows you the current values, minimum, and maximum of each spec.

$\endgroup$
-1
$\begingroup$

OK, nevermind.

I ran the BMW benchmark and it maxed out my GPU. The video is just a very simple render.

It's working.

$\endgroup$
  • 1
    $\begingroup$ Make tests on your systems to determine the optimal size for the render tiles (in the performance section) Modern GPUs work better with large tiles (around 256x256 is a good starting point for a test) $\endgroup$ – cegaton Jan 27 '16 at 23:22
  • $\begingroup$ Also use auto tile size add-on to quickly make sure you are using the right tile size for optimised render speed. $\endgroup$ – hawkenfox Jan 29 '16 at 8:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.