2
$\begingroup$

I'm learning to work with the fire and render it in Cycles. After setting up the domain shader (to make it invisible), I see the mesh-emitter without fire.

enter image description here

What is my mistake and how to fix it?

$\endgroup$
7
  • $\begingroup$ Did you do a quick test using "Quick Smoke" ... you can follow the instruction here blender.stackexchange.com/questions/18599/… $\endgroup$
    – hawkenfox
    Commented Jan 26, 2016 at 14:43
  • $\begingroup$ Switch to CPU rendering, density is not supported on GPU. $\endgroup$ Commented Jan 26, 2016 at 14:43
  • $\begingroup$ @hawkenfox Yes, I originally created this scene using the Quick Smoke $\endgroup$
    – Rumata
    Commented Jan 26, 2016 at 15:03
  • $\begingroup$ @Jerryno I see ... And it is possible to render the fire and smoke in the Cycles on the GPU? $\endgroup$
    – Rumata
    Commented Jan 26, 2016 at 15:03
  • $\begingroup$ @MrZak Thank you very much, I'll try this method, is it suitable for rendering on the GPU? $\endgroup$
    – Rumata
    Commented Jan 26, 2016 at 15:04

1 Answer 1

2
$\begingroup$

In this smoke setup the smoke and fire won't be rendered because:

  1. Attribute node which provides information for shaders has property typed incorrect, it should be density.
  2. There isn't any Attribute with property for flame.

To fix that:

  • either use Quick Smoke operator from 3DView header > Object > Quick Effects which will setup objects and materials automatically. You can choose what type of smoke sim you'd like to in operator's options in the Last Operator Panel (in the Toolshelf). The materials will be setup appropriately:

    quick smoe options

  • Automatic setup may be not desired if there is domain / flow already created (you could link materials though from objects created with Quick Smoke to your main ones). So it's possible to correct spelling of the property manually and add one more Attribute node which will be connected to the node tree via one more Add node.

See related question: Rendering Smoke in Cycles

$\endgroup$
3
  • $\begingroup$ Thank you very much, it works! It looks like the smoke simulation may be rendered in cycles on the GPU? That's great! I also added some nodes to adjust the smoke and fire (postimg.org/image/6c4xn1jkd), using this tutorial: youtu.be/oSiV5gg_lCs Thank you! $\endgroup$
    – Rumata
    Commented Mar 6, 2016 at 16:11
  • 1
    $\begingroup$ @MaximVelichkin Glad it worked for you. As for GPU, I think it's supported in 2.77, though in wiki it's stated otherwise. Unfortunately I can't make any tests. $\endgroup$
    – Mr Zak
    Commented Mar 6, 2016 at 16:30
  • $\begingroup$ Smoke rendering is supported in GPU starting with version 2.77 $\endgroup$
    – user1853
    Commented Mar 21, 2016 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .