2
$\begingroup$

I have a .blend file that is almost 100mb (hence why I can't upload the file to blend-exchange.giantcowfilms). I've been trying to append other 3 other objects into a new file, and the file is just so huge and slow. I tried resizing everything to a much smaller size but that didn't change the file size. I tried decimating everything too but that just made everything look horrible.

I've uploaded the file to google drive:

https://drive.google.com/file/d/0BzCN0fElYa3HVklHME5rYTdhazg/view?usp=sharing

How can I get this down to a decent file size?

Thanks

$\endgroup$
1
$\begingroup$

Have you turned on file compression?

enter image description here

Other Alternative would be to zip - trying to zip a already compressed file would make little difference - your file up and try other cloud services like dropbox or mega.co.nz. if your file is just too big.

If you file contains animated simulation data, it's wise to delete them before uploading the file. Also you will want to keep what is necessary to discuss the issue you were having, meaning deleting all the other elements that would not matter to the problems on hand.

CONCLUSION 78mb on the one circuit board object named "curve.001". It's the poor conservation of polygons. Meaning your object have too many polygon for it's purpose. The film strip object is too high res in the mesh count too, with very bad topology if you want it to bend nicely along a bezier curve.

$\endgroup$
  • $\begingroup$ Unfortunately the compress file option didn't minimize the file size, but thanks for letting me know about that feature...didn't know about it. I'll upload it to google drive and hopefully then you or someone can have a better picture of what I might be doing wrong. $\endgroup$ – lakerice Jan 26 '16 at 7:16
  • $\begingroup$ I think I found the offending object in your scene ... what I did was delete object randomly and look at when the file size start to drop drastically. There is a circuit board sort of object in the joystick model that contribute about 65mb of file size to the file alone ... am diagnosing the issue there. It's pretty high res model 1.76 million triangles. $\endgroup$ – hawkenfox Jan 26 '16 at 8:24
  • $\begingroup$ I conclude it's 78mb on the one circuit board object. I guess it boils down to poor conservation of polygons. The film strip object is too high res in the mesh count too, with very bad topology if you want it to bend nicely along a bezier curve. Pick up the subject on "topology". $\endgroup$ – hawkenfox Jan 26 '16 at 8:31
  • $\begingroup$ Thanks hawkenfox I had no idea it was the circuit board...too bad because I liked that part. I wonder how people are able to make super detailed movies in blender without their file sizes becoming gargantuan. $\endgroup$ – lakerice Jan 26 '16 at 22:04
  • $\begingroup$ They would use normal map and tricks to make low polygonal object look like they have high mesh count. It's important to note that you need to plan before hand what is required. If you need to view your model really up close you may need those physical polys, but if the view distance is far off , you could just get away with applying a texture image to a simple box. An example would be, in a architexture visualisation , you wouldn't care to model the screws on a furniture because they are just too small... you could use texture to create those details if it's really necessary. $\endgroup$ – hawkenfox Jan 27 '16 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.