1
$\begingroup$

I'm new to Blender and have just started to learn texturing in Blender. The problem is: when I apply textures to the default cube displayed at startup, the work and render perfectly, but when I add a new mesh (regardless of whether I deleted the cube or not) the texture doesn't render at all and most of the texture options are completely missing. I'm not sure if it is a malfunction or if I'm doing something wrong. I tried reinstalling Blender and I also tried a previous version (Blender 2.75) and the same thing keeps happening. I would really appreciate it if someone could give me some advice. Thanks in advance.

$\endgroup$
2
$\begingroup$

You might have missed this step.

For every new mesh you create, you need to apply at least one material. Without the material applied your texture panel will be empty. This is the confusing part of blender. Though it can be improved, after working with blender for a while, I find it fairly easy to use.

TAKE NOTE

There are 2 Panel you need to be aware of whilst starting to learn about material. The material panel and the textures panel are separate panels, but they work together.

Also I am assuming that since you are a new user, you would be on Blender Internal Render engine and not cycle. Hope this helps.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.