2
$\begingroup$

Was reading up some interesting answers on animating noise. Until, I found out that blender 2.75 doesn't have the same interface as shown on the image below.

Does anyone know how to turn on Open Shading Language in the cycle renderer? Following the post here How to animate noise texture "seed"? I was not able to see the noise on screen at all. It outputs the noise as plain white.

cycles osl button location in version 2.70

$\endgroup$
  • 3
    $\begingroup$ OSL isn't available on GPU. If you are already set to CPU, it's possible your version of blender was compiled without it. Are you using an official build from blender.org? (btw, any particular reason for using 2.75? The latest version is currently 2.76) $\endgroup$ – gandalf3 Jan 24 '16 at 8:18
  • $\begingroup$ Previously I had installation issue with 2.76 not registering properly so the blend thumbnail did not appear on the windows explorer. Yes I am running the official version from blender.org. I read on some other forum that OSL option was going to be available since 2.65 tho. $\endgroup$ – hawkenfox Jan 24 '16 at 16:11
  • $\begingroup$ Yup , I can comfirm the problem was my default startup on the cycle setup was on GPU. Changing to CPU did made those Open Shading Option appear. Thanks. $\endgroup$ – hawkenfox Jan 24 '16 at 16:19
  • $\begingroup$ Read about it in the manual but couldint find it in Blender, now I realized I needed to switch to CPU render first. $\endgroup$ – eromod Jul 26 '16 at 3:40
-2
$\begingroup$

OSL isn't available on GPU. If you are already set to CPU, it's possible your version of blender was compiled without it. Are you using an official build from blender.org? (btw, any particular reason for using 2.75? The latest version is currently 2.76) – gandalf3

$\endgroup$
  • $\begingroup$ Now who is the joker that voted down the answer lol, wasting our time here to check. $\endgroup$ – hawkenfox Jan 25 '16 at 18:50
  • $\begingroup$ I have set my options to CPU only on a machine that has two GTX-970s. With CPUs off, there is no Open Shading Language available. $\endgroup$ – Doug Kimzey Jul 22 '17 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.