1
$\begingroup$

All I want is to add a single texture to a plane which will display in the game engine. To do this, I

  1. unwrap a mesh in edit mode
  2. open UV image editor
  3. open image... its a pgn. but ive tried with jpeg as well with no luck.
  4. In materials, add new material and click plane
  5. In texture, add new texture and use the Image or movie and then under Image, I select my image file.
  6. I change the view port from solid to textured.

With this process, I can see the image projected onto the plane. I can also see it when I hit f12 to render. My problem is, that when I start the game engine, the image texture does not show on the plane. All I get is the original grey plan that I started with.

I've already tried switching to GLSL mode. Any suggestions would be greatly appreciated. I've meticulously tried all of the suggestions offered on the forums and haven't had any success. Thank you.

Here is the blend file reference

My computer's graphics card.

Display Devices

      Card name: Intel(R) G41 Express Chipset (Microsoft Corporation - WDDM 1.1)
   Manufacturer: Intel Corporation
      Chip type: Intel(R) 4 Series Express Chipset Family
       DAC type: Internal
    Device Type: Full Device
     Device Key: Enum\PCI\VEN_8086&DEV_2E32&SUBSYS_2A9D103C&REV_03
 Display Memory: 1582 MB

Dedicated Memory: 64 MB Shared Memory: 1518 MB Current Mode: 1600 x 900 (32 bit) (60Hz)

$\endgroup$
0
$\begingroup$

I have downloaded and test the file which you have attached. Pressing P does reveal the image in the game engine on my screen.

I suspect you user preferences setting were different from mine.

Now that I see your graphics card, I am suspecting it could be a hardware/software limitation. I went on the internet and search for OpenGL driver for the card. And it seems that you have to download a package to enable OpenGL support. Maybe you could read up here and download the appropriate OpenGL package for your card?

Link here https://downloadcenter.intel.com/download/20046/OpenGL-Support-Web-Link

Link to the G41 Express Chipset here https://downloadcenter.intel.com/product/81517/Graphics-Drivers-for-Intel-G41-Express-Chipset

Hope this will resolve your issue, good luck.

enter image description here

$\endgroup$
  • $\begingroup$ I have attached the link to my .blend file under my original post. Thank you. $\endgroup$ – Curtis Jan 25 '16 at 4:09
  • $\begingroup$ I am using the default user preferences. Do you have any suggestions on what user preferences I might change? Perhaps my computer isn't fast enough? Thank you for your feedback. $\endgroup$ – Curtis Jan 25 '16 at 4:21
  • $\begingroup$ I tried the suggested and now when I enter game mode, the image and the plane disappear completely. However in render mode, the Mario character shows correctly without the plane outline. $\endgroup$ – Curtis Jan 25 '16 at 4:44
  • $\begingroup$ Dont worry about the transparency for now ... I have included that because I guess it's the final effect you may want ... since you are dealing with a transparent PNG. I can't seems to make the image disappear on my end ... so we know what needs change. $\endgroup$ – hawkenfox Jan 25 '16 at 4:50
  • $\begingroup$ See my updated answer. $\endgroup$ – hawkenfox Jan 25 '16 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.