4
$\begingroup$

I'm using Blender 2.76b with the internal renderer. Whenever I render a simple plane with a texture applied to it, I get a small border on the edges that consists of a mix of the expected texture color and the color on the opposite end of the texture. The same thing happens when using the add-on called "Import Images as Planes".

The texture settings I've tried so far:

  • Enabling and disabling repeat
  • Disabling Mip Map
  • Disabling Interpolation
  • Different filter types
  • Filter Size 0.10
  • Enabling Minimum Filter Size

The filter size seems to have the biggest impact but even the lowest possible value doesn't get rid of it entirely. See the example on the lower left for best visibility:

Plane rendered against white background

Blender files:

One way I could think of to fix it would be to add some empty space around the texture image. But since I'll be using my objects outside of Blender and I haven't encountered this elsewhere, I'm a bit hesitant about the wasted texture space. Is there any other way to fix this?

$\endgroup$
  • $\begingroup$ Pictures are your friend, please add as much relevant information as possible so that people wanting to help can do so without guessing at what's on your screen. $\endgroup$ – Timaroberts Jan 24 '16 at 5:37
  • $\begingroup$ @Timaroberts Thanks for your advice. I've added a picture and rephrased some parts. $\endgroup$ – Eric Jan 24 '16 at 9:08
  • $\begingroup$ I am assuming you also have these simple .blend files you already set up to test render. Wouldn't harm to load the .blend files so we could examine them with less assumptions and more accuracy to the issue on hand. $\endgroup$ – hawkenfox Jan 24 '16 at 19:11
  • $\begingroup$ @hawkenfox Good idea, thanks. I've added them to my question. $\endgroup$ – Eric Jan 24 '16 at 22:04
1
$\begingroup$

Try playing with the 'Image Mapping' in the Texture panel. If you change the 'Extension' from Repeat to Clip, the edge gets blurred with the background. Choosing 'Extend' yields a harder edge on the outside.

Extension set to 'Clip':

Texture Clip

Extension set to 'Extend':

enter image description here

$\endgroup$
  • $\begingroup$ Ah, that's exactly the setting I needed, thank you! And thanks for also taking the time to show the difference between clip and extend. $\endgroup$ – Eric Jan 25 '16 at 4:36
  • $\begingroup$ @Eric You're welcome. The repeat option is actually pretty nice if your working with tiled textures. Checkered.... ? no idea. $\endgroup$ – dval Jan 27 '16 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.