2
$\begingroup$

I was following this tutorial about creating a spaceship in Blender:

As advised I created 3 background images for the three views to be uploaded via the properties bar (N). I did not fail to switch to the ortho mode with the NumPad 5, so that is settled.

After importing the three pictures there is a problem: I assign for example the top view background picture to the top view, NumPad 7 and it is visible. As soon as I assign, say the front picture to the front view and I switch back to the top view, the picture cannot be seen there any more. I have been trying all around for hours and I always end up with the only the last assigned background picture visible and the others then "gone". I run blender 2.76 in portable mode. Anybody any idea?

Sorry for the bad link, I forgot to set the filefolder to visible to others except me... Since my status does not allow to upload more than the 15 screenshots here is the correct link

I think I managed to generate a .blend with the images stacked. The link to upload it in MrZak's post did not work though. I am posting an alternative for the download.

I have read through your advised literature. The load UI was not unchecked.

Meanwhile I have noticed that whenever I try to save the project in the .blend, only the last uploaded picture/blueprint remains, even with the image packed. This means that when I open it, only the last picture remains.

Again sorry for any inconvenience with my virtually poor formatting skills and I much appreciate your efforts.

$\endgroup$
  • $\begingroup$ How many background images are there now in your file ? If there're more then one, are they set up as different images and for different views ? $\endgroup$ – Mr Zak Jan 23 '16 at 9:11
  • $\begingroup$ @Mr Zak. Thank you very much indeed for your reply. There are 3 images and they are set up each for different view. In the tutorial, the user uploads 3 pics. one after the other and then he assigns them to each respective view: top pic to top view, etc. Then he switched back and forth to the different views and the uploaded pics appeared so he could carry on with his project. Whenever I want to switch back to a previous view, the pic does not show anymore. $\endgroup$ – Carsten Steffin Jan 23 '16 at 16:10
  • $\begingroup$ @Mr Zak. I actually just completed a quick and dirty screenshotcast viewable through this link: picasaweb.google.com/102685929754019575402/23Januar2016# Hit slideshow and F11 for full screen and SPACE to stop the auto slideshow. You can then leaf through every pic with the right cursor key. $\endgroup$ – Carsten Steffin Jan 23 '16 at 17:46
  • $\begingroup$ Could you please upload a .blend which has images packed please ? I'm afraid link is leading to error404 but anyway looking into file should resolve this faster $\endgroup$ – Mr Zak Jan 23 '16 at 18:06
  • $\begingroup$ @CarstenSteffin istead of sending us to a faulty link, please edit the images you mentioned to your original question, use blender.stackexchange.com/posts/45471/edit and add the screenshots of your project and upload your blend file using the link on Mr Zak's comment $\endgroup$ – cegaton Jan 23 '16 at 18:59
4
$\begingroup$

I have attached a file with 3 views. Try hitting Num 7 , Num 1 and Num 3 to view the different elevation views. Everytime you add an image to the background you will have to click on the "Add image" button. I believe that may be the reason why you could not get more than one image to show up on your viewport.

enter image description here

Alternative Methods

However there is a better way of working with image plane. Using import image as plane. Here you get a polygon created to match the aspect ratio of your image and the image is applied as a shadeless material. This gives you more control in positioning your image planes and make them visible in all views including the perspective views.

Note : You may also want to turn on lock transformation for the planes.

enter image description here

Here is the download for the alternative method.

$\endgroup$
  • $\begingroup$ @ hawkenfox. Thank you so much for your support. I have saved the files you have provided. Currently I am a beginner in Blender and I just want to master the first chapter (modelling) in the most simple manner to possibly evolve from there step by step. That is why I am kind of clinging to the tutorial mentioned above. My mind needs those step by step walktroughs. I will try and apply your methods if I don't come out with my problem above. They are honestly a bit confusing today. $\endgroup$ – Carsten Steffin Jan 23 '16 at 17:54
  • $\begingroup$ If you are interested though: I actually just completed a quick and dirty screenshotcast viewable through this link: picasaweb.google.com/102685929754019575402/23Januar2016# Hit slideshow and F11 for full screen and SPACE to stop the auto slideshow. You can then leaf through every pic with the right cursor key. $\endgroup$ – Carsten Steffin Jan 23 '16 at 17:55
  • $\begingroup$ Sorry about that one, I forgot to change a setting in the filefolder. I added the correct link in my initial post above. $\endgroup$ – Carsten Steffin Jan 23 '16 at 21:46
2
$\begingroup$

To have multiple background images press the Add Image button for each one of the images and views you want to use.

By default images show in all views, but you can assign them to specific views, using the option for Axis:

enter image description here

Here's an example of different images used for different views:

enter image description here

(clik on the image to enlarge)

Note: Background images can only be displayed in:

  1. Camera Perspective view (Numpad 0)

  2. Any of the preset orthographic views which you can access using the keys on the number pad:

    • Front/Back (Numpad 1 or CtrlNumpad 1)
    • Right /Left (Numpad 3 or CtrlNumpad 3)
    • Top/Bottom (Numpad 7 or CtrlNumpad 7)

Background images will not show in perspective view. To switch between perspective and orthographic view use Numpad 5

Background images are used for reference only and will not be part of the final render.

$\endgroup$
  • $\begingroup$ Got it now! The tutor was going so fast I missed something. Thank you all so much nevertheless and I wish you all the best from Hamburg Germany. $\endgroup$ – Carsten Steffin Jan 23 '16 at 22:14
0
$\begingroup$

I would add one more step to the answer from @hawkenfox (which I upvoted by the way, because it was a good answer).

After you load your image as a plane zoom a camera up on it to fill the camera's viewport at the correct scale and aspect ratio.

Then set the origin point of the image plane as the camera's origin, and parent the plane to an empty that is also at the origin of the camera. Then parent the camera to the empty.

This way:

  1. Whenever you move just the empty both the camera and the Image Plane come along for the ride.

  2. If you ever have to scale the image outward away from the camera to put scene items in, the perspective should never change

  3. Your background will always be ready when your camera is.

  4. If your background is bigger than the camera, you can always rotate the camera and leave your background image un-rotated, but still linked to the camera via the empty.

This won't be ideal in every situation, but not a bad trick to keep up your sleeve.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.