1
$\begingroup$

I created an animation in blender, exported it as a series of png files, used the blender video editor to merge them as frames in a clip, and continued to add sounds, transitions, etc. to complete the scene.

When I attempted to export the final product to a video file, all of the frames were re-rendered, but instead of the correct color view they rendered as greyscale scene view (essentially not even rendering anything). All of the images were overwritten instantly, and the previous hours spent rendering were wasted.

Now, I'm trying my hardest to re-render the entire scene, but every time I try to render the animation (or even just a still image), it keeps rendering the greyscale image scene as opposed to the actual product. How can I fix this? Also, once this is fixed, what is the proper way to render the final video?

$\endgroup$
  • $\begingroup$ Have you added Scene clip in the Video Sequence Editor before rendering movie for the first time ? Also I'd add that before starting to render frames to still images which may take much time it's a good idea to render them in a different folder other than one by defalut. Thus rendered data will be saved. $\endgroup$ – Mr Zak Jan 22 '16 at 12:17
  • $\begingroup$ In the Post Processing section of the Render Settings Disable Sequencer or remove any strips from the VSE $\endgroup$ – user1853 Jan 22 '16 at 15:22
  • $\begingroup$ Disabling sequencer solved my issue. Thanks for the help. $\endgroup$ – Dan Jan 22 '16 at 21:17
0
$\begingroup$

Go to Node-Editor change it to COMPOSITING and press Shift+A for adding an IMPORT --> Movie Clip. Connect Image from Movie Clip with Image Composite.

enter image description here

$\endgroup$
  • $\begingroup$ Doesn't appear to have worked, it's still rendering the greyscale scene $\endgroup$ – Dan Jan 22 '16 at 11:56
  • $\begingroup$ Have you connected the two points as the image shows? You also have to delete the connection between Render-Layers and the Composite. I'm sorry I didn't write it in my answer. $\endgroup$ – Joseph Dark Jan 22 '16 at 12:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.