0
$\begingroup$

I do not have much experience with blender. I have a fbx model that i got from unity asset store, this has UV mapping already and a texture. I have tried to get the texture showing on the model but cant seem to be able to do it, i opened the UV Image editor and open the image there but it does not appear on the model.

The second part is once the texture is actually mapped onto the model, how can i change the camera angle and export as transparent png file, i will use this to make an icon. I am using blender version 2.7.6

The files i am using are below https://drive.google.com/open?id=0B8DB8JYjVWbTb081LVQ1dmtjck0

The image renders like below hen2

$\endgroup$
  • 1
    $\begingroup$ The question seems alittle weird the way it's phrased. You don't usually change the camera angle to created transparent png. Rather it's the rendering setting you will need to change if you are planning to do a render output. Now there seems to be 2 problems here 1. you cant see the texture and 2. how to output a rendered image with transparency? $\endgroup$ – hawkenfox Jan 22 '16 at 4:19
  • $\begingroup$ Thats right two problem, i mentioned camera angle because i may want to change what is rendered so the object is facing the camera, not from left or right side. $\endgroup$ – tsukimi Jan 22 '16 at 4:57
  • $\begingroup$ It would be useful to upload the model and pack the texture so that we could troubleshoot the issue for you. You can use the link blend-exchange.giantcowfilms.com $\endgroup$ – hawkenfox Jan 22 '16 at 5:00
  • $\begingroup$ Your textures are missing from your .blend file, to include them go to file>external data> pack all into .blend, and upload your file again. $\endgroup$ – Timaroberts Jan 22 '16 at 6:25
  • $\begingroup$ i have added the blender file again with textures packed $\endgroup$ – tsukimi Jan 22 '16 at 6:36
1
$\begingroup$

Importing the FBX

  1. Use File>Import>.fbx to open hen_bin.fbx
  2. Select the mesh and enter Edit mode.
  3. Go to UV/Image editor and click on the little photo icon to the right of the word "Image". The icon will say "Browse Image to be linked" when you hover over it.
  4. Choose the image from the list that appears "Map #1949".
  5. Change your 3D view port to show textured materials (Alt + Z) and you should see your texture appear some what, but with blocky shading issues.
  6. Finally, with your chicken selected, go to "Object Data" and turn OFF auto smooth. It should look very nice.

enter image description here

Changing the camera view: Have you tried fly mode?

  1. Press NumPad 0 to look through the camera.
  2. Press Shift + F to enter fly mode. You can look around with the mouse, and can fly around with WASD, QE, and speed up or slow down fly speed by scrolling up or scrolling down with the mouse.
  3. When you find the view that you like, simply left click OR hit Enter. Your camera is set!

Rendering a Transparent PNG

  1. In Render settings under "Shading", change "Alpha" from the default "Sky" to "Transparent".
  2. Render
  3. F3 to open save image dialogue
  4. Save as PNG with RGBA (using panel buttons on the left) enter image description here enter image description here Happy icon making!
$\endgroup$
  • $\begingroup$ thanks for the update, i have updated my question, i got to the "object data" part not sure where to find that, is that the cause for how the chicken looks in the screenshot in the question? $\endgroup$ – tsukimi Jan 24 '16 at 12:57
  • $\begingroup$ ok i found the "auto smooth" option $\endgroup$ – tsukimi Jan 24 '16 at 23:37
  • $\begingroup$ Im now at render stage , 2 problems the model has no texture applied and the model is too small , the camera is too far away, i updated the question with new image $\endgroup$ – tsukimi Jan 25 '16 at 1:12
  • $\begingroup$ i added a texture and material and also scaled it, now it renders well. Is this the best way to render it? $\endgroup$ – tsukimi Jan 25 '16 at 1:40
  • $\begingroup$ Also under materials->shading i turned on shadeless since the image was too dark in places $\endgroup$ – tsukimi Jan 25 '16 at 4:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.