1
$\begingroup$

I'm new to Blender. I've got a scene, I downloaded from an Internet forum about a year ago, but light isn't working.

If I create a new file, add a mesh and shine a light on it I get light.

When I follow the same process in the scene I want to light the spotlight has no effect.

Any ideas?

enter image description here

lighting panel

Thanks to @Timaroberts it appears the scene is upside down or something.

When I move the lamp underneath the plane and rotate it the scene lights as expected.

enter image description here

$\endgroup$
  • $\begingroup$ Can you show a screenshot of the lamp's settings panel? $\endgroup$ – PGmath Jan 19 '16 at 16:10
  • $\begingroup$ @PGmath thanks for taking a look. I updated my answer with a screenshot. i.stack.imgur.com/0aYVt.png $\endgroup$ – David Silva Smith Jan 19 '16 at 18:11
  • $\begingroup$ If it is on layer one you need to turn layer one on or move the light to layer one. The layers are represented by the grids at the bottom of the window. If a square is greyed out it is off. $\endgroup$ – Dontwalk Jan 19 '16 at 18:25
  • $\begingroup$ Are the layers your light and mesh live on, both being rendered in the 'Render Layers' under the 'Scene Tab' in the 'Properties Panel'? $\endgroup$ – dval Jan 19 '16 at 18:35
  • $\begingroup$ Did you create the light in Blender internal, or game? If so, it may not work in cycles. The same goes for materials. $\endgroup$ – Uncle Snail Jan 19 '16 at 20:00
1
$\begingroup$

It looks to me like the energy settings of the lamp, in wireframe you won't see the lighting, and your rendered viewport looks normal for a single spot at default values. Change the lamp's strength to a higher value, or you may use a plane with an emission material and you will see your scene much more clearly.enter image description here

$\endgroup$
  • $\begingroup$ thanks for the detailed answer. I added the emission plane and I got the same result until I moved it below my plane. Then I noticed if I move the lamp below my plane and rotate it to shine up it works as expected. It seems my scene is upside down or inverted or something... $\endgroup$ – David Silva Smith Jan 19 '16 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.