3
$\begingroup$

I'm trying to create polygon hair like final fantasy characters in blender for blender game engine can someone help me out in creating good quality texture with z-transparency I have already tried with alpha texture maps but it do not display properly when I run the game.

$\endgroup$
  • $\begingroup$ For more personal help, come to our chat where we can communicate realtime. $\endgroup$ – Scalia Jan 16 '16 at 16:34
0
$\begingroup$

I can help you display alpha maps, but I'm sorry I can't help you with the hair specifically.

Displaying alpha textures in the BGE

Step 1

Set the scene shading to "GLSL". Alpha textures don't work in the default "MultiTexture" setting. If you create a new game scene, you will have to repeat this step.

enter image description here

Step 2

Add transparency to your material!!! Unless you specifically tell blender, it won't know how to use the alpha you've given it. Check the "Transparency" option under the material tab, set it to "z-trace" and pull the drag bar all the way down to zero (0).

enter image description here

Step 3

Now you need to make some changes to the texture settings of your object. Assuming you've already given the material a texture, you only need to do a few things:

  • Enable "Use Alpha"
  • Enable "Alpha" under the "influence" tab

enter image description here

$\endgroup$
  • $\begingroup$ Note: Semi-transparency works in multi-texture mode too. But the material settings slightly differ. $\endgroup$ – Monster Feb 2 '16 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.