-1
$\begingroup$

In Blender I'm using a video texture (with alpha) with transparent gradients to show an interface on a wall. But while I want the gradient to give light, it makes it darker. See image below (the vertical dark gradient behind the green interface):

Gradient makes it darker instead of lighter

As you can see the gradient is making it darker, while in the video it is a light green transparent gradient.

Does anybody know why this happens?

Here is my node setup:

Node setup video texture with emissive material

$\endgroup$
  • 2
    $\begingroup$ Can you add more detail to the question. What does the "gradient" look like? I'm having a hard time understanding what is the desired effect you are looking for. $\endgroup$ – cegaton Jan 15 '16 at 17:44
  • 1
    $\begingroup$ Please show a frame of the (.mov) in the image editor window. Is it really 100% transparent in the likely areas? Is that transparent BSDF color 100% white? Can you show your mesh objects in the area of interest. I am assuming you can add more images. Are they any other meshes in that area? $\endgroup$ – atomicbezierslinger Jan 15 '16 at 18:22
  • 1
    $\begingroup$ Can you show the area in question with and without the image in the rendered. Before and After image in render. $\endgroup$ – atomicbezierslinger Jan 15 '16 at 22:17
  • $\begingroup$ Thanks a lot for your replies! This was my first post. Next time I will be more descriptive... $\endgroup$ – Maarten Jan 18 '16 at 9:14
2
$\begingroup$

SIMPLE!

  1. Plug your texture straight into the emission node, and have that go straight to the output.
  2. Go to the "cycles settings" for your object you would like to use as a lamp.
  3. Disable shadows and camera.

Now it will emit light, but will not cast a shadow, or be seen by the camera. Using this method also eliminates the confusion of using light path nodes.

There is an illustration below. The top render is a plane emitting light with shadow and camera turned off, and the bottom is a normal plane emitting light. enter image description here

Hope this helps.

$\endgroup$
  • $\begingroup$ Thanks a lot for your help! While experimenting with your answer I found the answer myself. It's the alpha rendering settings in After Effects. $\endgroup$ – Maarten Jan 18 '16 at 9:15
1
$\begingroup$

After trying out the answer of Uncle Snail, I found out that my original settings work just fine with png files. After some testing I found out that the alpha channel in the video is the problem. In After Effects it should be set to 'Straight (Unmatted)' instead of 'Premultiplied (Matted)'. See image below. The premultiplied rendering causes a black halo around the transparent gradient.

enter image description here

After setting the rendering of Quiktime to Straight I got a good result:

enter image description here

$\endgroup$
  • $\begingroup$ Keep in mind that PNG files and unassociated (straight) alpha can't produce a pure emissive transparency (lighting effects are). You have to use EXRs instead, that are associated (premultiplied) with zero alpha. In cycles just plug your texture to the emit shader and use an add shader node to add that emit shader to a transparent shader. That will give you a correct associated luminous shader that can be properly composited as light. $\endgroup$ – Gez Feb 14 '16 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.