1
$\begingroup$

First, I have created both a plane and a curve object, then I adjusted their dimensions as desired. Noticing that the scales of both changed with the dimensions, I press CtrlA after the re-dimensioning of each of the objects, with that object being selected alone.

Till here, everything is fine, both objects have now the desired dimensions with a scale of one.

The issue is: When I add a curve modifier to the plane and choose the curve previously created in that modifier, the plane dimensions change for some reason! :s

Any idea why?!

EDIT:

Link to an example blend file:

Go to the modifier tab of the plane object and select the curve called Circle to see how the dimensions of the plane change!

$\endgroup$
8
  • $\begingroup$ Screenshots and a ~.blend file uploaded to a site like Blend-exchange might allow someone who wants to help give a better quality answer. $\endgroup$ – brasshat Jan 15 '16 at 11:13
  • $\begingroup$ I tried to upload a .blend file, but I got a 'fatal error' when I pressed upload on Blend-exchange :s $\endgroup$ – Beginner Jan 15 '16 at 11:29
  • $\begingroup$ @Beginner please try uploading again, the issue on Blend-exchange has been resolved ad it should work now. Once you upload successfully please use edit your question and add the link to it: blender.stackexchange.com/posts/45017/edit $\endgroup$ – user1853 Jan 15 '16 at 19:05
  • $\begingroup$ @cegaton Thanks for the note, I added it in the edit $\endgroup$ – Beginner Jan 18 '16 at 7:38
  • $\begingroup$ @MrZak The plane is supposed to just move from its current position to become centered around the circle curve. It should have nothing to do with subdivision. To get what I mean, try creating a circle and a plane without any dimension modifications, and apply the curve modifier to the plane. You will see that the plane does not change dimensions. My final goal is to add an array modifier before that curve modifier and sweep the plane around the curve. $\endgroup$ – Beginner Jan 18 '16 at 10:16
1
$\begingroup$

Solution Found!! :D

Modifying the dimensions of the objects in EDIT mode solves the issue. It seems that my previous method of modifying dimensions in OBJECT mode does not actually modify the dimensions but applies a transform to the objects. And when the plane gets associated to the curve via the modifier, it seems that the transform of the curve gets also applied to the plane, which results in the weird change in dimensions I was observing.

Anyway, problem solved... Thanks to all those who tried to help!

$\endgroup$
2
  • $\begingroup$ there should be a better way ? $\endgroup$ – gordie Sep 3 '19 at 11:31
  • $\begingroup$ Solved my issue as well thanks. Seems that this could be a checkbox on the Modifier.. Something that says: Preserve Plane $\endgroup$ – Antony P. Apr 16 at 16:23
0
$\begingroup$

from Reddit:

The curve actually is read from the first control point of the curve.

And begins bending at the origin of the mesh (but this can be changed based on the offset of the curve origin to the object origin), While being rotated based on the rotation of the curve's first control point.

So the setup i usually go with is set the first control point in the curve to the origin of the curve (0.0,0.0,0.0 by default). Then extend the second control point in whatever axis you're going to curve in. You can hold [ctrl] while moving and rotating to snap it. If you have difficulty w/ the the bezier curve, try a nurbs curve with the first two control points set to xyz 0,0,0.

Then parent both the mesh object and the curve to an empty. Then on the mesh object press [g] to grab, and then [x] , [y] or [z] depending on which axis you're curving on, then you can just move and rotate the empty to move the whole object. You can move on the local axis by pressing the axis clamp button twice, so to move on the local x axis, you would press [g] + [x] + [x] , this way you an still tweak it after rotating the empty.

$\endgroup$
0
$\begingroup$

This scaling problem happened to me too. I noticed that at some point I modified the curve radius by selecting all the control points in Edit Mode and pressing Alt + S. After I reset its value to 1 my object looked okay again.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.