0
$\begingroup$

I can't figure out why the mirror modifier is being applied to the face that left or right of one it should be

As far as I can tell my origin point is centered and my mesh is symmetrical. I have not moved my origin point nor moved the mesh in object mode.

Shows Problem

Shows Problem

Shows Problem

Shows Problem

$\endgroup$
  • 1
    $\begingroup$ it's hard to give you a good answer to your question without seeing the settings you used in the mirror modifier panel. Best idea is to upload a copy of your ~.blend file to Blend exchange or a similar site. One thing to consider, though, is whether you applied your scale and rotation. Also, looking closely at the figures above, the 3D cursor and the object origin are do not coincide exactly; the two items have a slight offset. $\endgroup$ – brasshat Jan 15 '16 at 3:29
  • $\begingroup$ related: blender.stackexchange.com/questions/353/… $\endgroup$ – p2or Jan 15 '16 at 10:52
1
$\begingroup$

My guess that your mesh is symmetric, but the symmetry axis is rotated. for example you rotated your Mesh in object mode. I am pretty sure that you did something like that, because you presumably used the default 32 vertices number cylinder, and in that case 4 vertices must be aligned to the coordinate axis by default, if you add your object to the center of your world, without tweeking the Add circe tool option... so it should look like this:

enter image description here

My hint:

Delete your extrude.

Apply Mirror.

Rotate your object (in object mode), to make the axis "cut half" the edges. Like this:

enter image description here

Apply rotation (Ctrl-a)

Recreate mirror modifier, and you good to go.

In the future for similar objects, you should rotate circles/cylibders like this if you wan them have symmetric handlers.The general formula for rotation for blender circle:

360/vertices_number/2 (if you use degrees. You can write it directly to the rotate property field)

(it will not work on your current object, because it is already rotated)

enter image description here

$\endgroup$
  • $\begingroup$ I should have thought about ctrl A. It seems to fixed the problem well enough. The model still is slightly off but not enough that anyone will notice. Thanks $\endgroup$ – Warlord213 Jan 15 '16 at 21:56
  • $\begingroup$ @Warlord213 If the answer is adequate you can accept it. $\endgroup$ – atevm Jan 25 '16 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.