2
$\begingroup$

When using the Blender Game Engine, the parts of the model viewed through the windows becomes transparent and it's not a clipping problem. If I select a glass object the model viewed through the glass object shows up properly.

transparency affects object view


I have tried both solidify and double sided and it doesn't help. If I select a transparent object, the object then shows the model through the object. When I press play, then everything works right. In the image I have selected the 'glass door' on the left and the object can now been seen, but not through the other windows. I hope this is alright to answer like this, as I don't see away to include an image in my comments.

enter image description here

$\endgroup$
  • $\begingroup$ Related: blender.stackexchange.com/questions/31558/… I'm assuming you're using GLSL shading mode? $\endgroup$ – Scalia Jan 15 '16 at 4:00
  • $\begingroup$ Yes I am using GLSL $\endgroup$ – Gordon McConnell Jan 15 '16 at 16:36
  • $\begingroup$ What does it look like inside the game engine? $\endgroup$ – Scalia Jan 15 '16 at 18:04
  • $\begingroup$ It look s fine when I press 'P' to activate the play mode $\endgroup$ – Gordon McConnell Jan 16 '16 at 5:09
1
$\begingroup$

My guess their normals are pointing to the opposite direction. One solution is to add a solidify modifier to it, or check in double sided in object data. The second option is maybe better for performance.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.