1
$\begingroup$

So I have this plane which emits small glowing orbs using hair particle (I'm stimulating a firefly field). I unchecked the "Emitter" option in particle settings as well as the "Transparent" option in render settings so that I will get the fireflies with a transparent background, the reason is I want to add a glow to it in the compositor.

The problem is, the plane is still showing in rendered viewport shading and also in the actual render, I don't know what to do anymore :|

Hoping someone might help me, I attached my file here: Blender File

Thank you in advance. :)

enter image description here

$\endgroup$
1
$\begingroup$

I downloaded your .blend file and solved it. The trick is the following:

Add a new vertex group, and assign every vertex to it.

Put a mask modifier at the end of your modifier stack and make it use the new vertex group, you should turn on the small double arrow button next to the vertex group input field to invert the mask selection. It will hide the original mesh.

like this:

enter image description here

$\endgroup$
  • $\begingroup$ Great! Thank you for the quick response :D Though when I rendered it using F12, the plane is still there. But I figured it out by moving the new mask modifier just below the particlesystem2 using the up and down arrows. Thank you very much for the help :D $\endgroup$ – James Clarity Jan 14 '16 at 16:22
  • $\begingroup$ Your welcome :) the order of the modifier stack is very important in almost every use case. $\endgroup$ – atevm Jan 14 '16 at 16:31
  • $\begingroup$ I'll take note of it :) One last question though, do you know why the "Emitter" checkbox didn't work? Is it with my node set up? I just find it odd for it not to work. $\endgroup$ – James Clarity Jan 14 '16 at 16:36
  • $\begingroup$ It works, but you must move the timeline to see them, because the emitting animation starts at frame one, and your blend file is at frame one. Try it. if it does not work I will send back your .blend file with working emitter. Another hint give normal velocity to your emitter particle system, to shot particles upward $\endgroup$ – atevm Jan 14 '16 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.