I have my preferences set to rotate view in 3D Viewport using the Shift+RMB.

This is what I am used to using in other programs and works great in Blender in Object or Edit Mode.

When in Sculpt Mode I can not rotate the view using the mouse+key combo. However in Sculpt Mode I can rotate using the Numpad 4, Numpad 6, Numpad 8 or Numpad 3.

I have looked for the setting to change in Preferences and answers online with no luck. Anyone know where to change the preferences for rotate view in different modes? Is that the problem?

Thanks for any help!

  • $\begingroup$ It works for me in all the interaction modes after changing "Rotate View" option in "3D View - Global" entry. Try restoring this shortcut back (there should be arrow to the right from top row which allows restoring key map item) and then again set it up as you'd like. Or reset user prefs just to see if something else affects there. $\endgroup$
    – Mr Zak
    Jan 13, 2016 at 20:22
  • $\begingroup$ Thanks and I tried that with the current file and it did not work. I did some tests and it seems like it is just the file that is causing the issue. A new blender file rotates using my preferences and the default preferences in Sculpt Mode. I guess the file is the problem? $\endgroup$
    – ned
    Jan 13, 2016 at 21:36
  • $\begingroup$ Not that I'm sure because any .blend uses those preferences in Blender's folder (there's kind of another way with setting up multiple configs but it's way too messy and I don't think you used that). This could be either bug or something with preferences indeed in that file. Did you try resetting all the prefs within it ? It's the most brutal way and it should've worked. $\endgroup$
    – Mr Zak
    Jan 13, 2016 at 22:26
  • $\begingroup$ One more thing to try is to open that file within Blender with Ctrl+O and uncheck Load UI in the bottom left. $\endgroup$
    – Mr Zak
    Jan 13, 2016 at 22:30
  • $\begingroup$ Tried to restore all prefs to blender defaults and that did not work. Also tried to open and uncheck the "Load UI". It is strange and I have also tried to remove everything (all objects) including cameras and lights and then adding a basic mesh, setting multi-res on it and then trying to rotate view in Sculpt but it doesnt work with this file. Also the pan or move mouse+key command does not work either. Let me know if I can send this file somewhere to be checked. Thanks Mr Zak for your help and suggestions. $\endgroup$
    – ned
    Jan 14, 2016 at 0:06


You must log in to answer this question.

Browse other questions tagged .