I would like to export a model from Blender with the colors and open/import it in Meshlab. Here my model:

Model with Colors

I read about it a bit already and did not find any conclusive answer. I know that the info should be stored in e.g. the .mtl file while using the .obj format. But neither did .obj, nor any other format worked. So therefore I might miss some necassery step. Like applying (?) the colors to the vertices ? I am just guessing here. Also the add material in export window did not help. I am guessing this is pure basics.

A second question regarding the same piece is how I can get rid of all the internals of my model (here with a boolean modifier using union). So e.g. in this wireframe model I want to get rid of the black part of the Letter R: Model in Wireframe Mode

So my final model would be yellow letter R, black cube and "hollow" inside without anything inside.

How can I achieve this ? Thanks.

  • $\begingroup$ That's probably the other mesh that you used in the Boolean Modifier. You can select it in Wireframe mode and just hide it with "H" or move it to another Layer with "M". $\endgroup$ – Samoth Jan 12 '16 at 21:29

For importing the mesh with colors into MeshLab:

In Blender, select File > Export > Wavefront (.obj), and select a location to save the .obj to.

Exporting from Blender

When the file browser opens as part of the export process, look at the panel to the left, and make sure "Write materials" is checked:

Export dialogue

Next, open MeshLab, and choose File > Import Mesh... and select the .obj you exported from Blender. This will import the mesh, but the mesh will be grey:

Grey mesh

To enable the mesh colors you exported from Blender, in MeshLab you need to navigate to Render > Color and click "Per Face". Your mesh will now be displayed with the colors you specified in Blender:

Colored mesh

For the second part of your question, you should be able to select the black wireframe by right-clicking on it, and then delete it by pressing X. Does that achieve what you need? If that doesn't work, or if you encounter problems, could you upload your .blend file please?

  • $\begingroup$ Thank you very much for taking the time and your detailed description. I did everything you said, but I could not make it work. None of the color options in Meshlab have a result , other than the default grey become a tick darker. Do I need to apply the colors ? Or do anything other than assigning them in the material panel ? Thanks again... $\endgroup$ – digit Jan 12 '16 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.