2
$\begingroup$

See this video for example: VIDEO EXAMPLE

When particles fall directly down, the collision object will kill all particles as intended. But, when I direct the emitter to give the particles an x or y velocity, the particles pass through the sides of the collision object as if it isn't there. None of the particles get killed by the collision object when they should be. I've tried this with multiple objects as the collision/killer object: cubes, spheres, tubes (made from cylinder and solidify modifier), darn near everything.

What's worse, is that it only seems to be with one particular .blend file (which so happens to be my work project file). Creating a new .blend file and setting this up doesn't seem to produce this error.

Can any offer a fix or solution to this? Is there a configuration setting that would make the particles pass through the emitter sides?

$\endgroup$
0
$\begingroup$

In my case, to solve I just put the emitter and the collider in the same layer, and close and open the Blender to make the bake of the particles again.

$\endgroup$
-1
$\begingroup$

I just tried this using a cube collider around a uv sphere generator, and it works fine. I guess this might refer to an older bug?

Also make sure that the collider and the particle system share at least one common layer, otherwise the collider won't affect the particle system.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.