1
$\begingroup$

I'm having another rendering issue that I can't seem to figure out. I have a video that, when rendered on my local machine, turns out as it should. However, the company that I am submitting the .blend to renders in the cloud, and when I receive the rendered PNGs back, there are faint black objects overlaying some of the scenes (similar to another question I asked about a Blender Internal video a month ago). This occurs in areas where scenes overlap in the Video Sequence Editor (as I am using a separate scene to composite multiple scenes). To allow the scenes underneath to show through, I've tried both editing the scene strips to have the "Alpha Over" blend setting and using "Alpha Over" Effect Strips. Both produce the same results. Currently, I am using the Effect Strip method. I'm curious if this is a common problem in the Video Sequence Editor, or if there is something wrong with my scenes. I'm using Cycles, and I'll post a shortened version of my .blend below.

Incorrect Render This is the result of rendering in the cloud. Notice the black shadowy cube that is present on the left side of the frame.

Correct Render This is what I want my render to look like. The black shadow cube is not present.

Video Sequence Editor This is what my Video Sequence Editor looks like when using Effect Strips.

VSE v2 This is the other method I attempted in the Video Sequence Editor, specifically changing the blend mode of overlapping scene strips to "Alpha Over."

Both set-ups yield the same result when rendered in the cloud.

$\endgroup$
  • $\begingroup$ Always make sure to mute underlying Strips that have an Effect Strip applied to minimize side-effects. $\endgroup$ – Samoth Jan 11 '16 at 16:58
  • $\begingroup$ Doing so causes areas not covered by the effect strip to no longer be visible when rendered. Also, even when I don't use an effect strip and simply change the blend setting of my scene strips to "Alpha Over," this issue still occurs. So I doubt this is related specifically to the use of an effect strip. I'll upload another screenshot with the method I described above. $\endgroup$ – Emelie K. Jan 11 '16 at 20:57
  • $\begingroup$ The Effect Strips have to have a Blend Type of Over Drop or Alpha Over if you want to have it "on top" of other Strips. Those other Strips of course don't have to be muted, only the original Strips where the Effect Strip is applied on. $\endgroup$ – Samoth Jan 11 '16 at 21:00
  • $\begingroup$ The only strips in my scene are the original strips and the alpha over effect strip that I created from them. So muting only the original strips means I'd be muting all of the strips except for the effect strip. And doing so, even with the effect strip set to "alpha over," still renders all areas the effect strip doesn't cover empty. I was hoping I could use alpha over as a means to connect two strips between their transition so that the bottom strip is visible through the upper strip's alpha channel. $\endgroup$ – Emelie K. Jan 11 '16 at 21:18
  • $\begingroup$ Yeah, never mind. My tip doesn't apply on Alpha Over Effect Strips. I'm looking at your Blend file and it's quite a Setup... The Black Shadow Cube comes from messing around with Render Layers and Masking and Blackhole Nodes and stuff... that's pretty complicated, no wonder something appears that shouldn't be there ;-) $\endgroup$ – Samoth Jan 11 '16 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.