0
$\begingroup$

I assigned mesh to one of my armature bones with weights between 0 and 1. However, when I am actually moving the bone in pose mode, it looks like it would be dragging all parts of mesh like there would be weights for all vertices assigned as 1.enter image description hereenter image description hereenter image description here

So I was curious how I could fix this?

$\endgroup$
  • $\begingroup$ Please show the armature settings in the modifier panels. What was the behavior you wanted to see? At this point you should assume there are many fine points of Blender rather than Blender has malfunctioned. $\endgroup$ – atomicbezierslinger Jan 10 '16 at 17:28
1
$\begingroup$

Choose the Parent Armature Deform best suited to you.

Check your modifier panel settings. Know that your bones in your example and mine are perpendicular to the rather linear mesh portion example. For limb animation and rotation for organic models the bone is often inside the mesh for major limbs. Consider making the bones parallel to the mesh. Consider blurring the weights for gradual transitions.

enter image description here

  • Try these settings above when you parent the mesh to the armature.

    You will achieve a more flowing gradient.

    [With Automatic Weights]

  • Try the other settings.

    You will achieve a more abrupt gradient.

    [With Envelope Weights]

Below Closeup Abrupt Influence with a little curve.

enter image description here

Below Closeup Flowing Influence with a big curve.

enter image description here

Another way to get abrupt influence in my example is to choose Bone Envelopes only in the modifier panel.

enter image description here

$\endgroup$
  • $\begingroup$ Oh, I see the point about parallel and perpendicular bones. However, I managed to make a trick with just making central and edge vertices present on that part of mesh (bowstring). Central 4 vertices are assigned to vertex group, while 8 edge ones are not (dl.dropboxusercontent.com/u/248943005/ballista/4b.png). $\endgroup$ – chanfort Jan 10 '16 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.