2
$\begingroup$

This question already has an answer here:

The texture does not show in UV editing mode, default mode or render. I have mapped the UVs and the viewport shading is set to textured mode as shown.

I tried adding a material (it was green) and the the render shows up as green.

In a different file the texture was showing and I didn't even add a material. How can I get the texture to show?

This is the UV editing screen enter image description here And the Default screen (I removed the material from all objects) enter image description here

$\endgroup$

marked as duplicate by Carlo, David Jan 10 '16 at 1:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3
$\begingroup$

For cycles, once you have your object unwrapped and textured like you have in your first screenshot, you then navigate to the material tab, and click "Use Nodes"

Now under "Surface" you should have a drop down which says "Diffuse BSDF", followed by 3 options; "Color", "Rough", and "Norm". Click the little dot to the right of the "Color" widget, and choose "Image Texture":

Selecting an image texture node

In the image texture panel, click the drop down to the left of the "Open" button, and select the image that you had open in the UV editor:

Selecting the image to be used

Now if you go into the textured view (Alt+Z), you should see your texture applied to your object.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.