4
$\begingroup$

I would like to have the default cube cast its shadow on the orange plane, but not the purple:

enter image description here

Is this best done with render layer? Can it only be done with render layers?

$\endgroup$
4
$\begingroup$

Unfortunately, I am pretty sure this is impossible to do in Cycles material nodes. You will have to do this in the compositor.

First place the object which you do not wish to receive shadows on a separate layer. Then create two render layers, the second of which excludes all layers except the one where you just put the object.

enter image description here
Everything is on layer 1, except the plane which should not be receiving shadows which is on layer 2. So I am excluding layer 1 from the second render layer.

Now give the shadowless object a pass index under Object Properties > Relations rollout.

enter image description here

And make sure you have the Object Index pass enabled for the main render layer.

enter image description here

Now head over to the compositor and use the object index pass to mix the second render layer onto the first one.

enter image description here

Here is the final result:

enter image description here

$\endgroup$
  • $\begingroup$ Sure.... what I am wondering is if render layers are the only way to accomplish this.... but thanks... this is useful and will be a good source. $\endgroup$ – rcgauer Jan 9 '16 at 15:42
  • $\begingroup$ @rcgauer Unfortunately I think this is the only way of doing this, due to the nature of how Cycles works ATM. $\endgroup$ – PGmath Jan 9 '16 at 15:43
  • $\begingroup$ Any updates on if this is possible using Cycles material nodes? $\endgroup$ – Coby Randal Feb 28 at 5:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.