3
$\begingroup$

I have a bit of a problem, at the moment I'm creating a few rocks for game purposes. Im starting of sculpting them and then baking them from multires, and applying that to the lowest "subdivision", just plain hi-res to low-res. Now the problem I have ran into is that when i use the lowest subdivision all my quads are "broken" and when rendered it looks all weird(I'm attaching a picture of it). And this is not a one time thing, this happens on every rock i create!

Now my question is, how do I solve this? without having to manually change every vert, which i tried but it took like 1 hour, and when i was done i noticed that changing them made a bunch of other quads get broken instead.

And is there a way to get around this completely? And i have also noticed that this only happens with Cycles and not with blenders internal render!

As you may see, the darker parts.

$\endgroup$
  • 2
    $\begingroup$ It looks like the terminator problem $\endgroup$ – PGmath Jan 8 '16 at 23:34
  • $\begingroup$ Well, It may be, I'm pretty sure its a render based problem as it only occurs in cycles, but the question you referred to didn't really have an answer! I mean I probably could play around using different light settings, but this is not just for one scene, so obviously the lighting and stuff like that are going to be different for every occasion! $\endgroup$ – user2866639 Jan 8 '16 at 23:42
  • $\begingroup$ Try adding a subsurf modifier to get more geometry. $\endgroup$ – PGmath Jan 9 '16 at 0:03
  • $\begingroup$ Yes That indeed solves it, but still isn't a solution I can use, as the whole point is to have as little geometry as possible! $\endgroup$ – user2866639 Jan 9 '16 at 0:55
  • $\begingroup$ If subdividing geometry is not an option then I think the solution is to change lighting. One lamp setup isn't good enough. Add 2-3 lamps, increase their size. This will make shadows softer and may (almost) eliminate the problem. $\endgroup$ – Mr Zak Mar 9 '16 at 11:06
1
$\begingroup$

Select your mesh.
In the object mode in the left panel of your 3D view there is bunch of options such as trnaslate and rotate and... In Shading section you can see smooth and flat button side-by-side.
Click on flat then you'll see your mesh as it is.

If you want to use smoth shading option, your mesh should be hi-res (at least a little bit) or it will be like what you can see in your attached image.

Take a look at this (the same object all the time): enter image description here

$\endgroup$
0
$\begingroup$

Blend in a very slight emission shade (eg. strength 0.1) using Pointiness as the fac of a mix shader node for your rock material only, that way you don't have to kill your lighting setup.

enter image description here

$\endgroup$
0
$\begingroup$

select ur lamp, go to right menu, in properties select sun, scroll down, click to lamp, set size value more than 1 (dont use Hemi fow lowpoly models) and all will be okay (answer for someone who will find this problem fix in google and will open this page)

$\endgroup$
-2
$\begingroup$

Have you tried this?

  1. Go into Edit Mode.
  2. Select all polygons / faces.
  3. Hit W Select "Remove Double"
  4. Hit Ctrl + N
  5. Hit W Select "Shade Smooth"

Note If those triangles disappear as you move your light sources in the viewport. Don't worry about them they are just viewport's limitations.

$\endgroup$
  • $\begingroup$ Yes Ive tried all of those steps unfortunately! I guess its just a "bug" or as you say limitation! Ive even tried adding more geometry and using edge split modifier, that does help, but still doesn't remove it all! But I guess its just one of those things you have to live with as it seems! $\endgroup$ – user2866639 Jan 9 '16 at 22:27
  • $\begingroup$ If at all possible do upload the blend file model, I am sure some of us would be interested to look at the trouble you are having and learn something from it. $\endgroup$ – hawkenfox Jan 10 '16 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.