1
$\begingroup$

I tried to use the Ocean Modifier, but couldn't get anything that resembles a realistic ocean. I tried everything from subdividing and distorting, to generating and playing with all the parameters. Nothing worked, I even tried changing the choppiness to some absurd value (see screenshot below). I don't need the ocean animated, just a freeze version of an animated ocean. So I also added Keyframes at Frame 1 and 100, but did not get a result there, either.

Choppiness 20

Update: Here's an example with lots of parameters tweaked, where I would expect to see any rough ocean surface, I only get a distorted plane:

Distorted Plane

$\endgroup$
3
  • $\begingroup$ Could you be more precise about what features is the modifier missing in order to achieve the realism you wish? I find, for example, that the default setting with increased resolution (about 20) and just a little bit more of choppines looks pretty good $\endgroup$
    – Carlo
    Commented Jan 7, 2016 at 12:15
  • $\begingroup$ I want it to look like a regular ocean surface and my result seems more as if it would miss the height and detail. My dream goal would be something like this: youtube.com/watch?v=DsMSRZ7b6g4 . But with breaking waves and not open ocean. But my first step is to get the regular ocean working. Understand how I can achieve this and there anything along these lines would be great: blender.stackexchange.com/questions/12356/… $\endgroup$
    – digit
    Commented Jan 7, 2016 at 12:33
  • $\begingroup$ And the default setting produces no result. However occasionally if I resart and just take the deafult plane, however not every time, it gives me the result. Kind of frustrating because I don't know what the problem is. I also changed the cache to the project folder which did not make any difference. $\endgroup$
    – digit
    Commented Jan 7, 2016 at 13:41

1 Answer 1

4
$\begingroup$

Resolution of the mesh vs Resolution of the simulation

There are two possible mode to take advance of the Ocean modifier. As stated by the Blender Manual's page:

Generate

Creates a tiled mesh grid that exactly corresponds with the resolution of the simulation data

or

Displace

Uses the existing geometry rather than replacing it. Vertices are displaced along the local Z-axis.

Basically, with Generated option enable a new mesh is generated. It resolution is the same of the simulation, and what it is inheriting from the starting objects are just transformation properties (location, rotation, scale, keyframes... and things like that). The geometry of the object doesn't matter

enter image description here

Switching to Displace option, means you are asking Blender to move the vertices of the mesh on the local Z axis (so keep an eye on the mesh rotation) according to a simulation.

If your starting geometry is made up of a single plane, increasing the resolution of the simulation won't result in a more detailed output, as it can be express only with already existing vertices only (4).

enter image description here

You'll have to increase the mesh-to-be-displaced too. You can use, for example, a subdivision surface modifier stacked above the Ocean modifier:

enter image description here

$\endgroup$
7
  • $\begingroup$ Thank you. This all looks fine and I appreciate the information/background. But unfortunately it is still the same I can occasionally create the ocean with the standard plane. But if I try to distort it looks the same. What should I do that this works ? I did not rotate anything. I just sized a plane to the size I need. Than it does not work. Shouldn't this work out of the box ? I don't get it. $\endgroup$
    – digit
    Commented Jan 7, 2016 at 14:46
  • $\begingroup$ Yes it should. Maybe there is something hidden in your file that prevent a correcect behaviour. I would suggest to upload one of your testfile to blend-exchange.giantcowfilms.com so we can inspect it better. What kind of distortion are you trying to perform? And how? $\endgroup$
    – Carlo
    Commented Jan 7, 2016 at 14:57
  • $\begingroup$ <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=848" /> $\endgroup$
    – digit
    Commented Jan 7, 2016 at 15:16
  • $\begingroup$ Modifiers are applied before object's transformation. So apply the scale (Ctrl+A) and then tweak the modifiers parameters (start from the default ones and increase the sim resolution first). Once satisfied, you can scale the result the way you want. $\endgroup$
    – Carlo
    Commented Jan 7, 2016 at 15:21
  • $\begingroup$ As mentioned above I would like to create an ocean with breaking waves. But not animated. Thanks for your help. $\endgroup$
    – digit
    Commented Jan 7, 2016 at 15:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .