0
$\begingroup$

First of all, sorry for my English. I am new to blender animation. I have a problem regarding material colours, my problem is I can`t get colour same like texture shading. any one can help me on this point. I am working in cycle render.

1) Texture Shading Viewport.

enter image description here

2) Render Viewport(cycle render).

enter image description here

How can set colour in render same as texture shading Viewport.?

$\endgroup$
1
$\begingroup$

what you have is this:

current

what you want is something like this:

target

what you miss is two things:

There is no light source in the scene. You can have lamps like in the following screenshot, ore use an image in the world background (yours is monochrome), or combine both.

light

the material setup only has a diffuse shader to it. This shader will only return diffuse color information, so specular lights won't show up anyways, no matter what you try. Mix the shader with for example a Glossy shader, which catches some reflection:

material

from here you can take it to however sophisticated you want. Add fresnel, maps, vertex colors, whatnot, but without proper material setup and proper lighting, no scene can look cool :)

$\endgroup$
0
$\begingroup$

I believe dirty vextex textures could help you. AndrewPrice made a good tutorial about it here: https://youtu.be/nX4dkwU1pyQ

You could also try to work with fresnel / layer weight: What does the Cycles Fresnel Node do?

Note that you are not in textured mode in your screenshot. You are in solid mode. The way how that behaves can be changed in Preferences > System > Solid mode OpenGL lights. (See here: https://www.blender.org/manual/preferences/system.html)

$\endgroup$
  • $\begingroup$ Yes, I forget to change object mode to texture mode but it look same like object mode. I trying your answer... thanx for help.. $\endgroup$ – hardwork Jan 7 '16 at 6:47
  • $\begingroup$ I hope the dirty textures help. Btw. how have you lit the scene? A rim light could do wonders to the thing. $\endgroup$ – Mörkö Jan 7 '16 at 6:47
  • $\begingroup$ If you look up rim light, you can well see what I mean: google.fi/… $\endgroup$ – Mörkö Jan 7 '16 at 6:49
0
$\begingroup$

The color you have selected in the Material > Settings > Viewport Color and Specular Color only affects the viewport. The reason being the viewport uses GLSL OPENGL shading model to display in realtime your mesh in the blend file. It has nothing to do with the output of colors in your final render.

In fact you can change the viewport material color to blue, and cycle will only take the color that is on the diffuse node. It's the diffuse node that cycle cares about. So you will never get identical representation of the final out put of the file until you select render preview in the viewport.

The use for viewport material color , is so that artist would not have a 100 object with the same color. You can imagine it would be difficult to differentiate high number of objects on screen with the same color.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.