5
$\begingroup$

I successfully downloaded and installed the VSE Transform tool add-on found at https://github.com/kgeogeo/VSE_Transform_Tools into my blender. Through the add-on, I'm able to click on the VSE viewport and move and edit things like images and movies around straight from inside it. The add-on actually works great, except for the way it works with keyframes.

To save any of my changes, I'm required to manually insert the keyframes. Automatic keyframing does not work. For example, if I create a keying set, add the location positioning properties of a transform strip to that new keying set, insert a keyframe, change the frame I'm on, and try to change location positioning through the add-on, no new keyframe is inserted even with automatic keyframing enabled.

Initial frame: enter image description here

100 frames and a positioning change later: enter image description here

The only way I seem to be able to keep any changes made is to manually insert a keyframe myself. In the same example, if I use manual keyframe insertion at the end, the changes keep.

I would like to note that the add-on actually came with its own additional way of inserting keyframes without a keying set, accessed by moving the mouse pointer over the VSE viewport and pressing the I key. Inserting a keyframe through this secondary method does not immediately show a new keyframe in either the dope sheet editor or the graph editor. The add-on appears to wait on inserting a keyframe until blender takes one more additional action (changing selection, changing frame, etc.). I feel as though this somehow might help explain why automatic keyframing doesn't work natively with it.

$\endgroup$
  • $\begingroup$ Seems to be something that has to be addressed to the Add-on devs. $\endgroup$ – Samoth May 18 '16 at 9:33
  • $\begingroup$ First, thanks for making me know this addon, it's fantastic. Now, I saw that you reported this as an issue in GitHub (I reported two issues more yesterday!). Did you report this in BlenderArtist thread? There are more interested people there who might fix this problem. $\endgroup$ – Mario Mey Oct 9 '17 at 12:09
1
$\begingroup$

I know this is an old post, but anyone else looking for this should know that I have fixed this feature and a number of other problems in my fork of VSE_Transform_Tools.

$\endgroup$
  • $\begingroup$ I just wanted to say THANK YOU so much for picking this up and improving Transform Tools. It was an amazing add-on originally made so much better now. $\endgroup$ – 3pointedit Jan 30 '18 at 10:05
  • $\begingroup$ Looks nice! What are the main differences between yours and the original? $\endgroup$ – Anson Savage Feb 2 '18 at 18:27
  • $\begingroup$ Checkout the releases page to see the first change log. Other than that, the snapping feature is new. In the addon preferences window, you have the option to install version 1.0.0. You can install that and see for yourself. $\endgroup$ – doakey3 Feb 2 '18 at 18:43
  • $\begingroup$ I added a youtube video to demo some of the changes. $\endgroup$ – doakey3 Feb 4 '18 at 4:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.