1
$\begingroup$

I have a plane with Reed sticks applied on as particles in Layer 1. These Reed stick Particles consisted of a group of objects with their own particles applied on another layer. These group of particles systems are in layer 2.

When I render the scene I can only see one Particles "called HAIR in the scene" I can not see " SEEDS and LEAVES" particles, even in the view port. I have double checked that hey are under same group objects. Can you please help me to find out what's going on? Thanks

Does hair get special treatment?

Cycles engine.

You can download the blend file here

enter image description here

enter image description here

Visibilities are on as shown below

enter image description here

$\endgroup$
1
$\begingroup$

Left Side 3D View Yellow Emitter in Layer 1.  Hair Particle System in Layer 2. Recursive/Heirarchical/Layered

Image Above

Right Side Render.

Left Side Yellow Particles Emitter in Layer 1. Group in Layer 2. Brown Cube Reeds. Golden Seeds. Green Leaves. Reeds, Seeds, Leaves are part of the emitter. The [join] mesh command used.

Nail Shaped Hair is the second Particles system of the reed emitter in Layer 2. The Hair appears as strands in the 3D View Window.

enter image description here

Image Above

Second Emitter complex in layer 2.

Primary

You have already successfully rendered the emitter and the hair particle system. I have done the same in a new file. I have not succeeded to render the non hair non emitter.

You could have a finished model with only the group particles hair system present. The seeds and leaves can be part of the emitter.

For the seed and leaves you can convert them to non particles and be part of the emitter. The particles system can be used to generate the model. Then press the button [convert] in the the modifier panel for the particle system. The hair particles remain. The emitter is now a complex of reed, leaves, seed. Your artistic needs would determine if that is suitable.

You do NOT need to convert hair. The [convert] of the hair seems to produce edges only which will need to use something like a solidify modifier

Secondary

I used a particle instance modifier ... different from a particle system ... and I could duplicate hair but not object particles.

Tertiary

I will seek a few more alternatives.

Older

Verify your Object Cycles Setting, Cycles Ray Visibility: Camera checkbox is [enabled] for the missing particles.

Verify your particle systems camera render option is TRUE

Under the object Duplication Panel for the missing particles make sure the either None or Frames are selected. Do not use Verts Faces Groups.

Verify all particles system generate particles for the frame above.

Verify that all materials are created for the render engine. Cycles Render is compatible with Cycles materials. Blender Render is compatible with Blender Materials.

Verify that the Render visibility is on for the missing materials. The camera icon in the outliner panel.

Verify that you have no transparency in your material.

$\endgroup$
  • 1
    $\begingroup$ I've double checked materials all are for cycles render, all objects camera and viewport visibility is on, yet still I can not see the other two particles $\endgroup$ – ideorium Jan 6 '16 at 18:32
  • $\begingroup$ I've checked the ray visibilities under cycles settings, and its on for all, nothing seems unusual here. However what I realised is I keep particles object groups in a separate layer, then the actual scene... do you think this could be causing some problems here? $\endgroup$ – ideorium Jan 7 '16 at 6:47
  • $\begingroup$ Did you investigate the Object Duplication Panel? ..... I tried experiments to have particles showing in 3D View with [objects ] particles on different layers. Layers can be excluded. Yet particles as you have witnessed can change the bring items into view from different layers. Have you only one render layer? I could not recreate your problem ... yet. Of course I can remove the whole emitter and thus all particle system. I will investigate again. I usually do not suggest this .... please consider posting a simplified file which has the problem. $\endgroup$ – atomicbezierslinger Jan 7 '16 at 14:15
  • $\begingroup$ ok, I checked the one dup panel but couldn't see anything weird there. I have added the blender file in the question content, thanks for the help $\endgroup$ – ideorium Jan 7 '16 at 16:26
  • $\begingroup$ Thanks for the answer, i'm gonna study it tomorrow proparly when i reach my computer, however briefly i have these things challenging my understanding right now :).. 1- So its not possible to use a particle emitter to emit other group objects with particles on, in order to do that , the group objects must be converted. Correct? 2- the actual emitter i want to be use is on Layer 1, whereas Layer 2 has group objects with their own particles on , so they can't be on different layers? 3- the layers which group objects on must be visible on the scene - layer panel? Thanks again $\endgroup$ – ideorium Jan 7 '16 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.