4
$\begingroup$

When I make a 3d model in blender and import it to unity the model has an incorrect size and im thinking the problem has to do with the units but I don't know what units to use while modeling in blender (cycles).

Another problem is that when I import it into unity it imports itself without textures so im thinking it has something to do with how I save the model in blender, right know im saving it as .blend

And the final problem is that when I import the model from blender to unity the y,x,z axis are inverted or weird.

Thank's in advance.

$\endgroup$
3
$\begingroup$

A Blender unit is per default 1m. You can display this in edit mode by the Edge Info checkbox the units can be enabled in the Scene Tab.

enter image description here

In order to import it correctly into Unity drag and drop the .blend file directly to your asset folder in unity, materials will be automatically created. Textures need to be imported and assigned manually to the material slots.

Behind the scene Unity runs Blender and does an .fbx export. You could also export the model manually. File -> Export -> .fbx for more control: Note that the export dialog provides settings to scale and change orientation of the used coordinate system:

enter image description here

$\endgroup$
  • $\begingroup$ So your saying that it doesnt matter if i save the model as .blend or .fbx the model still isn't going to import to unity w ith the textures and i have to import the textures seperately and add them manually ? $\endgroup$ – user18723 Jan 5 '16 at 19:24
  • $\begingroup$ @user18723 That's the way it works best for me, When you double click the imported model in Unity (to refine animation actions, model glitches or whatever) the textures will be stil assigned. One user here mentioned that he was able to import the textures directly when they were appropiate named (some scheme like that objectname_texname ) $\endgroup$ – stacker Jan 5 '16 at 20:50
2
$\begingroup$

Very similar to @stackers answer, but all you have to do is uncheck the little box next to the scale.

enter image description here

Without doing that, blender will export the file in it's own measurements, so while it may read 1m in blender, it will act like it's converting the measurements from metric to imperial or something random like that. That's because blender's measurements are different to the fbx's or unity's. Therefore when you put it into unity, the measurements will be completely different.

$\endgroup$
2
$\begingroup$

This is an update for 2.79, as there was a new option added named 'Apply Scalings', and leaving it at its default setting of 'All Local' will result in the same scale problems in Unity regardless of whether the button to the right of the 'Scale' value is checked or not.

You need to make sure 'Appy Scalings' is set to 'FBX All' (or any other option that has FBX in, apparently). I'm not entirely sure what this option does, but my scale problems went away after changing it from the default.

FBX export Apply Scalings set to FBX All

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.