I have problem with lighting of my scene in Blender Game.

I need a lamp that light object on its layer and the objects on the layer ray shadow on all layers. But object on other layers do not ray shadow of the lamp and do not specular of the lamp (only receive shadow from object on layer where the lamp is).

I'm including simplified blend file to show the problem.


I have there 3 layers: Layer1 - white objects Layer 2 - blue Layer 3 - Red.

Lamp from layer 1 should light only white objects, but the object should cast shadow on all objects (red and blue cube)

Lamp from layer 2 should light only blue cube, but the shadow from the cube should be casted on all objects.

The same for layer 3 with red cube.

Is it possible to handle this? If not, meybe u know any alternative?


1 Answer 1


It looks like the "this layer only" setting on the Lamp includes "this layer only" at the shadow too (without explicitly setting this checkbox).

You might workaround that by using a second set of lamps that creates the shadows only.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .