2
$\begingroup$

Update: Added edge split modifier, now it works. I don't understand any of this.

I'm going crazy over this. Tried rendering in 2.75 and 2.76b. Same result.

I have this piece of a sword that just looks completely different on the final render than on the preview. And all the "render" vs. "view" settings are completely identical. And there are no object that render but are hidden or vice-versa.

The material is a mix of anisotropic and glossy, in the top right you can see the rendered .png and at the bottom it's my 3D view in render view. Do you see the black artifacts? They just won't go. I tried messing around with the subsurf modifier or rotate the mesh, but some black crap always appears anyway.

What the hell is going on

Just have a look at this. How come is the final render so different from preview in this simple case below?! (just Fresnel->Emission)

enter image description here

I don't understand what's going on. I thought the final render ought to be the same as preview in general. Let me repeat: subsurf has 3 subdivisions for the "View" and also 3 for the "Render". That's not where the difference's coming from.

Please, help me!

$\endgroup$
  • $\begingroup$ Ok, but it tells me I have to wait 1 more day until I can accept my own answer. Guess that's because I don't have much reputation/karma here. $\endgroup$ – I want to make games Jan 4 '16 at 16:04
  • $\begingroup$ Thank you for the friendly tips. I would surely elaborate on the issue, if I could, but I already said everything I know. I don't understand this problem and why the fix fixes it :/ Cheers! $\endgroup$ – I want to make games Jan 4 '16 at 17:19
1
$\begingroup$

Added Edge Split modifier, as suggested in a similar question -->here<--. Now it works.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.