2
$\begingroup$

In my quest to improve rendering times with Cycles I managed to break my file (I think). Now, when I enter (or slide the cursor) an e.g. 12 value in the Samples box, I get the following message: bpy.context.scene.cycles.samples = 1 Can't edit driven number value, see graph editor for the driver setup.

Choosing a preset from Sampling Presets doesn't reset the sample value.

I've even tried to open the Python console and set it from there, but it still doesn't change the UI, nor the actual render. Consequently nothing (visible) renders with a sample of 1.

Any pointers on how to revert my rendering samples much appreciated.

| improve this question | | | | |
$\endgroup$
  • $\begingroup$ This is such a fundamental feature the issue is likely quite deep, I'd recommend deleting the file(s) and re-downloading the .zip and running it. $\endgroup$ – VRM Jan 3 '16 at 18:51
  • $\begingroup$ Is it perhaps the input field filled with a different colour than the others? $\endgroup$ – Carlo Jan 3 '16 at 18:58
  • $\begingroup$ Whether the Samples slider is pink? Seems that you added driver to the samples amount. Hover mouse over that samples value and press Alt+D (delete driver).This can be done also from Graph Editor (like proposed by Blender) but it's a little bit more complex. $\endgroup$ – Mr Zak Jan 3 '16 at 19:00
0
$\begingroup$

Remove Drivers

You may have somehow added a driver to that value (e.g typing #frame in the field).

Drivers can use properties, numbers, transformations, and scripts, to control the values of properties.

By assinging a driver to the Samples quantity, you are basically telling Blender to pick the value from somwhere else (e.g. scripted expressions,...).The manual inputs will be overrided till the driver is present.

enter image description here

To delete a driver, right click on the field and choose the option from the pop-up menù.

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ Hi, Carlo: Yes, that was it, my field was pink and it had a "10" driver associated with it. I went to the Graph Editor and looked for something out of order, but I didn't see anything. Thanks for the help! $\endgroup$ – Virgil Gheorghiu Jan 3 '16 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.