3
$\begingroup$

I have a 30 second Scene, that I put at 3 minutes into my VSE - together with some additional "scene music".

When I play this in the VSE, it works fine - both audio and video.

But when I go to an animation panel to create/tweak my animation and hit play, the audio plays the intro from the beginning of the sequencer edit - which doesn't have anything to do with my Scene's audio.

Yet I need that "scene music" to time match my Scene correctly.

Any ideas about Sequencer time vs Scene time?

$\endgroup$
  • $\begingroup$ Guess you just need to grab your keyframes of your animation and place it way back to match to the frames where your Scene is put into your Sequence in the VSE. Adjust your Start and End Frames of your Scene accordingly. If this won't work for you (it did for an animation that I did some time ago) you should explain yourself more detailled and probably provide an example blend file or a timeline sketch of what you are talking about ;-) $\endgroup$ – Samoth Jan 3 '16 at 20:03
  • $\begingroup$ This is developer.blender.org/T49261 $\endgroup$ – mardy Mar 11 '17 at 20:36
2
$\begingroup$

Adjust the Start and End Frames of your Scene to match the Frames where you placed your Scene into your VSE. Then if needed grab your animation keyframes in the Dopesheet Editor and reposition them accordingly.

$\endgroup$
  • $\begingroup$ thanks... is that the only solution? so each time I want to move/tweak a bit of my scene in my sequencer edit, I have to "move all the keyframes + change scene frame start/end + adjust the strip's start/end frames" just so it can get the right audio outside of the sequencer? it's a bit cumbersome and is a bit limiting to creativity/iterating/trying things fast... $\endgroup$ – David Steiner Jan 3 '16 at 20:34
  • $\begingroup$ Well, you might be able to write a short script to automate this task ;-) (adjust Start, End and Keyframes). But it's the only way I know and which worked fine for me. So I won't say there can't be another solution. $\endgroup$ – Samoth Jan 3 '16 at 20:37
  • $\begingroup$ as outlined in comment of the @Samoth's other answer, to have the sound from the Sequencer play in 3DView too (to tweak the scene with sound), just put the scene strip at frame 1, and have stuff happen in the scene later... good luck! $\endgroup$ – David Steiner Jan 3 '16 at 22:38
  • $\begingroup$ @DavidSteiner Maybe the new nested Scenes support since 2.77 might help you out here? You could position your other Scene strip that includes your scene audio strip into your other scene and check "Use Sequence" in its Scene Panel. $\endgroup$ – Samoth Jun 2 '16 at 14:22
  • $\begingroup$ Thanks a bunch... I'll try that on my next project with blender! $\endgroup$ – David Steiner Jun 3 '16 at 22:44
0
$\begingroup$

As the VSE Sequences and the Animation and Object Data are Scene dependant, you might consider adding (or renaming the default "Scene" to) a "Master" Scene for your VSE Sequence where you import your second new to be created "Animated" Scene with your other stuff. There with the "Animated" Scene you open the VSE once, place the right Sound at the right position and switch back to your "Master" Scene.

To toggle between the "Master" VSE and the "Animated" Scene you just need to switch between Screen Layouts as for each one your currently active Scene is saved as well. So the correct Sound corresponding to your current Scene should always be played back.

$\endgroup$
  • $\begingroup$ Worked for me in a short test animation ;-) Seems the other solution is not the only way anymore that I know -.- (never stop learning!) $\endgroup$ – Samoth Jan 3 '16 at 20:48
  • $\begingroup$ yup, trying something at the moment, interesting idea to switch scenes! thanks, keep you posted $\endgroup$ – David Steiner Jan 3 '16 at 21:53
  • $\begingroup$ Good luck.. well, it worked for my test setup, so it should work for you as well, be confident. Blender is awesome ;-) $\endgroup$ – Samoth Jan 3 '16 at 21:57
  • $\begingroup$ ok, my main concern is that I want the same sound in the sequencer, and when tweaking my scene in 3DView (to time it precisely). since in 3DView blender plays the sound from the sequencer, it seems it doesn't make sense to put frame strips on any other place than starting at frame "1"... so I did what you said: move keyframes around frame 1000, have "nothing" happen in the same before frame 1000, and voilà! audio from frame 1000 in the sequencer plays in frame 1000 in 3DView... thanks! $\endgroup$ – David Steiner Jan 3 '16 at 22:36
  • $\begingroup$ Yeah, but your 3D View is always dependant on your currently active Scene and it's corresponding VSE sound strips. And if you want to be able to even move your included Scene around in the VSE you might consider using a driver for setting the sound start position in your animated Scene so it matches your animation. Didn't try this out. $\endgroup$ – Samoth Jan 3 '16 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.