I tried to put an object that was animated (quick effect- smoke- fire) over a video (.mp4) and in the compositor section, I am sorta lost as to what is supposed to go there (I followed a tutorial), and the fire is all that rendered in the final animation.
Blender fire animation

  • 1
    $\begingroup$ for future reference: how to take a screen shot $\endgroup$
    – David
    Jan 2, 2016 at 0:49
  • $\begingroup$ Moreover making screen grabs on blender is quite easy: press Ctrl+F3 and save. $\endgroup$
    – user1853
    Jan 2, 2016 at 2:47

1 Answer 1


Look under Render Options for the Shading settings. Alpha is set to "Sky" by default, which will remove transparency from your rendered image by filling it with the sky gradient colors (by default a simple dark gray color). That Alpha Over node needs this transparency. Set Shading > Alpha to "Transparent" to make the rendered image transparent.

an example of the Shading settings


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .