3
$\begingroup$

I love this program! But for some reason I keep having this problem! The video clip is not sped up, or altered in any way. It's just cut off.

enter image description here


enter image description here
My FPS does match my file, I checked and double checked! That was my problem before... Some of my videos work, while others are cut off. I use the same recording software and settings for both. This is crazy and I'm very upset. The video is not slow or glitchy at all! Just CUT OFF.

$\endgroup$
  • 1
    $\begingroup$ Your project framerate doesn't match the one of your Video file. $\endgroup$ – Samoth Jan 1 '16 at 18:23
  • $\begingroup$ related: blender.stackexchange.com/questions/43298/… $\endgroup$ – cegaton Jan 1 '16 at 18:45
  • $\begingroup$ @cegaton: As it seems to be a timelapse video here I won't count it as a real duplicate, but it's related of course. $\endgroup$ – Samoth Jan 1 '16 at 19:16
1
$\begingroup$

Set your project Frame Rate properly to match the one of your footage.

Mikeycal Meyers has got some great tutorials on this topic. He explains it pretty well in #2 - Blender Video Editing (Importing video) starting at 3:35. If you want to do speed change stuff instead you should follow his #24 - Blender Video Editing (Speed up & Slow Down Audio/Video | Snap Strips option)

So to fix it for you, you need to calculate your footages frame rate and set it up in Blender. You can do so by dividing your Audio Length (which is 42389 as you can see on your teal/lightseagreen/darkcyan colored Strip after the "|") by your Video Strips Length (that 3284 next to your darkblue strip) that is about 12.907... When you then multiply this result by your current Frame rate (which is 30 right now in your Properties) to get the Footages Frame Rate. Which is about 2.32418... in your case. It seems to be a timelapse Video Capture with a pretty low frame rate.

Here the result isn't a already predefined common Frame Rate. So you need to select a "Custom" Frame Rate in your Properties and leave this FPS setting at 30 and use this 12.907... as your Framerate base below (you can directly enter "42389/3284" into the box and let Blender do the math. Your result should be the "Custom (2.34 fps)" in the Frame Rate Dropdown box.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.