2
$\begingroup$

I'm organizing my blender files and realized when I moved a file that has an image on a plane in it, it lost access to it and the plane just shows pink. I hadn't realized the image was never made part of the blender file, it just pulls it from the original image file whenever I open it.

Now I know I'll take advantage of that in future by placing imported images in folders with their blender files so I can modify them if I want. But I'd like to change the path this file uses to find the image it is using. Otherwise I'll have to learn to use the UV/Image editor to re-apply it, which I think will take longer. I'm not into that kind of work yet.

Can I go into the file in an editor, find the path, and change it?

$\endgroup$
  • $\begingroup$ To make the image part of the blend file you can pack it. In the main menu select File->External Data->Pack All into .blend $\endgroup$ – cegaton Dec 31 '15 at 17:36
  • $\begingroup$ @cegaton I tried that and it didn't work for some reason. In fact, the self-answer I put below also hasn't quite worked for two other files that had the same problem. It found the file, but it is shaded deep magenta now. $\endgroup$ – kim holder Dec 31 '15 at 17:38
  • $\begingroup$ @cegaton i can edit the answer to include that, or delete it if there is a better one, if i can figure out why the image is colorized now and correct that. $\endgroup$ – kim holder Dec 31 '15 at 17:54
  • $\begingroup$ pink means two things usually: missing texture (including unreachable path) or texture mapped incorrectly. $\endgroup$ – cegaton Dec 31 '15 at 18:06
  • $\begingroup$ @cegaton it seems to have been an artifact - it was there when i opened the file to show a missing texture as you say, and the tone stayed there even once the image had been restored. Closing and reopening the file made it go away. $\endgroup$ – kim holder Dec 31 '15 at 18:08
3
$\begingroup$

Alright, I found it now. I clicked on File > External Data > Find Missing files, and the File Browser opened, and I clicked the 'Find Missing Files' button on the top right. The folder open in the File Browser needs to have the image in it or it won't work. If you aren't sure where it is, you can click the top entry in the System tab at left and have it search the whole hard disk, or click the up arrow at the top of the folder and file list in the main window area until you are confident it must be somewhere in there.

The image was tinted deep magenta after I did this, but it was there. Closing the file and reopening it caused that to disappear, it was an artifact.

$\endgroup$
2
$\begingroup$

You might want to try

  • File->External Data->Make All Paths Absolute
  • save the blend file
  • move to new location
  • Optionally use File->External Data->Make All Paths Relative and re-save

When saving relative paths, blender will start from the current blend files location to find the external files, which is why moving the blend file breaks finding the external data. By saving with absolute paths blender can find the same external files no matter where you the current blend file is.

By default blender will save relative paths, but you can disable relative paths in the File Preferences.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.