3
$\begingroup$

When I export an obj with settings so the vertex order is intact and then import it back into Blender with import settings set so vertex order is still intact, the resulting shape key works but the entire model rotates 90 degrees depending on the orientation settings from import/export obj settings. I have found no way to remove this rotation data. In other applications the way it would be fixed easily would be to reset the Xform or freeze transformation. I know Blender doesn't have this type of function so I have no idea how to fix this issue. Here is a link to a youtube video I made of this problem. Youtube video showing problem.

$\endgroup$
  • $\begingroup$ If you watch the video you have posted again. You will see that your original object has Z pointing up. One the imported model you will see that it's Y is pointing up. That's the root of the problem. Y up is for exporting to game engines like UDK. If you have intention to use your export in blender make sure to export it Z up. $\endgroup$ – hawkenfox Dec 31 '15 at 16:45
2
$\begingroup$

Everything is working exactly as it should.

When you import an object blender will rotate it so that it lines up with the blender world. The rotation is determined by the import settings Forward and Up.
OBJ import

All you have to do is apply the rotation ( CtrlA > Rotation ) on your imported object before making the shape key.
You will have to remake the shape key, or rotate the mesh in edit mode.
If you use the edit mode option you will want to set the 3D cursor to the original object's origin then set the Pivot Point to 3D cursor ( . ).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.