8
$\begingroup$

Here's a problem I've been having a lot of with Blender: I have a mesh, and I want to select all of its faces, so I do a box select like so:

selecting polys

However, this never works right. It always skips some polys as can be seen here (note the thin black triangles that are not selected):

not all polys are selected

If I try again it may or may not add a few more polys to the selection. Sometimes, if I zoom in I can select a few more, but not always. What am I doing wrong?

$\endgroup$
  • 1
    $\begingroup$ Try checking the "Limit selection to visible" checkbox... When it is checked, you can see thru the wire mesh in edit mode and box selections will select vertices or faces on all faces. When off, you are only selecting the visible faces/vertices.... Might this be it? $\endgroup$ – rcgauer Dec 29 '15 at 19:52
  • 1
    $\begingroup$ I did check the "Limit to visible", but that's not the problem since all the faces are visible. I can press the 'A' key to automatically select all of the faces, and that does work, but sometimes I just want to select part of a mesh, like if I just wanted to select the X and T letters in the above example, and that's just not possible for some reason. $\endgroup$ – BGreenstone Dec 29 '15 at 22:31
  • $\begingroup$ Related - blender.stackexchange.com/questions/38808/… $\endgroup$ – Mr Zak Dec 29 '15 at 22:50
7
$\begingroup$

There are several ways to select every vertice of the mesh not changing view angle in the scene.

Limit Selection to Visible

Uncheck Limit selection to visible.

enter image description here

If it's checked, it won't be possible to select vertices which aren't pointed to the viewer (like in your case).
If it isn't checked, when selecting either with Box select or with RMB (doesn't matter how) vertices on the other side of the mesh will be added to selection.

Wireframe viewport shading

Use Wireframe shading mode, accessible via shortcut Z while in 3D Viewport.

enter image description here

Selecting connected geometry

Select parts of a mesh connected to already selected elements.

Use Ctrl+L shortcut for that or from menu Select > Linked.

You can also select linked data directly under the cursor.

Press L to select linked data and Shift+L to deselect data which is located under cursor. Read more about selecting linked in the wiki page.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Right, but once again this was not the case. Clearly from the screenshots we are not dealing with hidden faces or any other form of hidden geometry. Everything is all right in front of the selection, get randomly different triangles will not be selected. Without Moving the camera, and simply doing another select I can often cause some of the unselected triangles to become selected. This appears to be a bug. $\endgroup$ – BGreenstone Dec 30 '15 at 1:56
  • $\begingroup$ @BGreenstone this isn't a bug. You use Solid viewport shading with Limit Selection to Visible turned on (I grab it to show what was selected). This means that possibility to select anything depends on camera view (and right, you won't be able to select every polygon, especially tiny ones, inside of area of Box select or whatever). One way to avoid that is to uncheck Limit Selection what was proposed in answer along with several other ways. $\endgroup$ – Mr Zak Dec 30 '15 at 11:44
  • $\begingroup$ @MrZak - no I think it is a bug, you are not replying to what BGreenstone reports. It is not about the visibility of the vertices. The problem is that Blender does not always select all the vertices that are visible. $\endgroup$ – antont Oct 31 '17 at 13:24
0
$\begingroup$

You are not doing anything wrong, it seems to be a bug / limitation of Blender selection.

As described in the question, a workaround is to select multiple times from different views. Pan, rotate, zoom etc. to select all you need.

With a dense mesh I did not get anything selected when viewing from far away. Zooming closer, I was able to select, so have been panning around the model selecting everything in partial segments.

I suspect it has to do with how the selection works from the viewport and somehow the accuracy of finding vertices based on the selection. Or maybe the amount of vertices: in my case, I have a huge 17M verts object and it selects nothing if I try to box select all visible. But when I go closer and select only some area, it starts working, and it's possible to select what you need, jumping around with the view.

My guess is that it has to do with using OpenGL for the selection queries and precision of how the vertices are in the graphics system, maybe it fails to find all when they are very close to each other in view. But succeeds when you zoom closer.

Would be nice if that could be fixed somehow, maybe the selection code could be improved somehow, I don't know it close enough to know whether it'd be possible.

$\endgroup$
  • 1
    $\begingroup$ If you think this is a bug then go ahead and report it. This is however not an answer to the question $\endgroup$ – Mr Zak Oct 31 '17 at 14:01
  • $\begingroup$ Certainly that answer is not completely clear yet as the problem is not fully known. It does however actually answer the question: OP asks what he is doing wrong. Answer is that nothing, it's a bug. I also suggest ways to deal with it: zoom, pan, change the view, add to the selection multiple times like that. Maybe would be good to edit those in more clearly, but that's what the text above already does say. Your answer however is basically completely off-topic and hence would be clearer to remove, no? $\endgroup$ – antont Oct 31 '17 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.