1
$\begingroup$

As the question title states I tried importing a svg file, went to Edit mode A to select ALL, and control F, selected tris to quad and it won't work. What am I doing wrong?enter image description here

here's the blend file

$\endgroup$
  • 1
    $\begingroup$ If I'm not mistaken, .svg imports as curve objects. Have you converted to mesh with Alt + C -> 'Mesh from curve/ meta/ surf/ text'? $\endgroup$ – Timaroberts Dec 29 '15 at 2:01
  • $\begingroup$ AFAIK tris to quads only converts where its easily possible to do so by dissolving a single edge. For something like this where you a have far higher number of verts on the inside than the outside, quads are just not possible without much more drastic measures. $\endgroup$ – gandalf3 Dec 29 '15 at 8:15
2
$\begingroup$

Try increase the maximum angle threshold, this will give you quads, but they won't be very square.

For better results, run: Mesh -> Faces -> Beautify Faces first.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi. Yes I had done Alt + C -> 'Mesh from curve/ meta/ surf, and i just tried Beautify too. No changes whatsoever. But thanks for your suggestions nonetheless. $\endgroup$ – Marc Dec 29 '15 at 4:41
  • $\begingroup$ Added the blend file to my question in case anyone has time to take a crack at looking at it... $\endgroup$ – Marc Dec 29 '15 at 4:47
  • $\begingroup$ @Marc, re: "i just tried Beautify too. No changes whatsoever" - The blend file does not look like the screenshot. so it seems you ran Beautify at some point. Loading your file and converting tris to quads works here without changing any settings. $\endgroup$ – ideasman42 Dec 29 '15 at 9:35
  • $\begingroup$ I don't know what you're talking about. My file looks absolutely no different than the first picture I uploaded. Yes.. I did run Beautify -- but it did nothing that I could tell. I STILL got nothing but triangles all over the place which makes it impossible to bevel the edges. If you managed to get it to change to quads I'd loooove to know how you did it. I go into edit. select all, mesh/faces/tris to quads ---annnnnnd NOTHING. To be sure I JUST tried it again, for the 10th time. NOTHING. Not that I doubt you but what am I doing wrong then? $\endgroup$ – Marc Dec 29 '15 at 16:35
  • $\begingroup$ @Marc, double checked - its very different, zoom in and see the distribution of faces on the on the ar, in the image these are aligned horizontally, in the blend they aren't. - Take the same screenshot from this blend file and you will see the difference. Also, running tris to quads on your blend file works here - so there is some strange disconnect here. $\endgroup$ – ideasman42 Dec 31 '15 at 8:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.