5
$\begingroup$

I'm making a video project in the VSE. My video is 3 minutes long however, when I render it I only get up to 10 seconds or less.

blender screen shot

It only reaches up to that part of the video. What can I do?
Do I need to select any specific settings to get the entire video to play it or am I doing something wrong?

$\endgroup$
  • $\begingroup$ Under the dimensions tab you have frame range set from 1 to 250. Try to increase that to 9357. $\endgroup$ – wout Dec 27 '15 at 21:38
  • $\begingroup$ I don't understand, why in your Timeline the End Frame (which is set properly) doesn't match the same setting in the Properties Area under Dimensions... it should automatically be synchronised. $\endgroup$ – Samoth Jan 1 '16 at 11:47
  • $\begingroup$ @Mahinsa: I just found it out by accident as I clicked around in one of my Movie projects... I updated my answer below. You need to uncheck this Setting "Scene.use_preview_range" in your Timeline/VSE. $\endgroup$ – Samoth Jan 20 '16 at 23:16
  • $\begingroup$ blender.stackexchange.com/help/someone-answers $\endgroup$ – Samoth May 17 '16 at 18:56
5
$\begingroup$

You need to change the End Frame in the render settings.
animation render settings
If you are rendering at 24 frames per second, and since you have a 3 minute video you will need to set the End Frame to 4320.


You also will want to change the render Resolution (it is right next to the frame range), now you have it set to 960x540, full HD is 1920x1080 but with the scale set to 100%.

Read the video rendering section of the blender manual for more information.

$\endgroup$
3
$\begingroup$

You can set your End Frame visually by selecting the last non-black Frame of your footage in the VSE and then hovering your mouse over the Timeline and pressing E for End Frame (as indicated in the Frame menu) or S for Start Frame to set it as your current frame (that's the green vertical line in the VSEs Sequencer View and in the Timeline).

But make sure, as in your case you did this "wrong", that you unselect the "Use an alternative start/end frame range for animation playback and OpenGL renders instead of the Render properties start/end frame range". use_preview_range Tooltip

As you can see in your Screenshot, you checked it: VSE & Timeline Screenshot

This causes your unwanted behaviour.

If it's checked, your Timeline Frame Range Settings only effect Playback (Ctrl+A), but when you render your Movie (Ctrl+F12), the Render Properties Frame Range will be used (both differ in your case 9357/250).

The 250 Frames are just 10.4 seconds (or 10 Seconds plus 10 Frames, you already stepped one frame backwards in your screenshot to 10+09) which were rendered in your case. The 9357 are nearly 6:30 mins, so this should be reduced to about 24 frames/sec * 60 sec/min * 3 min = 4320 Frames.
Uncheck use_preview_range and then your End Frame in your Timeline should show 250 as well as it is now set to in your Render Properties. You then need to set your End Frame to approximately the mentioned 4320 and you're fine.

Oh and usually you should set your Start Frame to 1, not 0. ;-) This makes your End Frame show/match your actual Numbers of Frames, else you need to increase it by one to get your final Frame Amount.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.