2
$\begingroup$

I made a model of a Rubiks Cube, with all of the little cubes inside of it separate. The cubes appear to clip into each other on turning.

Here is an example:

image

If anyone could help, that would be amazing.

$\endgroup$
2
  • $\begingroup$ Looks like you used shape keys instead of rigging. That would cause this kind of interpolation. Is this the case? $\endgroup$
    – Mentalist
    Dec 27, 2015 at 0:17
  • $\begingroup$ @Mentalist I didn't use shape keys. All I did was make 27 separate cubes, and then rotate these 9 with the rotate tool. Do you have any idea why this may be happening? It was done in Blender 2.7.2. $\endgroup$
    – Tritofic
    Dec 27, 2015 at 0:36

1 Answer 1

3
$\begingroup$

You have nine separate objects selected, and "Add Keyframe" made animation curves for each object. Because they are separate, each goes it's own way, on separate lines. You can see the orange dots moving on their own straight lines, instead of a circular path.

To fix this:

  1. Clear the current curves.
  2. Bind the objects to a shared parent while keeping their offsets.
  3. Animate the parent only.

EDIT: You say in your comment that you will be animating more rotations. For that case I have two ideas:

  1. Easy mode: move the object centers to the cube center, so all orange dots will be in the same global position. Then rotation along the three axes will move the meshes along a circular path.
  2. Advanced mode: Python script as driver for object position and rotation. This is harder to set up for beginners, but it can result in a shared controller for all 26 objects.
$\endgroup$
5
  • $\begingroup$ That would work if it wasn't a Rubiks cube. With the Rubiks cube, I need to be able to maybe turn that side, and then turn others that intersect with it. I can provide an example if you request it. $\endgroup$
    – Tritofic
    Dec 27, 2015 at 17:39
  • $\begingroup$ @Tritofic It would be nice to have such details as part of the question, because it looked like it is for a one-time animation. $\endgroup$ Dec 27, 2015 at 20:49
  • $\begingroup$ I apologize about forgetting that detail in my original post, but thank you for helping me out. The easy solution worked out fine for me, so thank you. Eventually, I may attempt to make the Advanced mode, but for now I'm good. $\endgroup$
    – Tritofic
    Dec 27, 2015 at 23:35
  • $\begingroup$ Wait a second, now there is another glitch. I actually tried animating it now, and it appears that on the second turn on, this glitch occurs: gyazo.com/0f61cba7f7cbd2845c83fa74e9000b9e Is there any to fix that? All I am doing is rotating the cubes from their centers which are all at 0,0,0. $\endgroup$
    – Tritofic
    Dec 28, 2015 at 1:37
  • $\begingroup$ I'm guessing the Bezier interpolation on the curves cause that "echo" from the first rotation. Go into the curves editor and set each of them to linear or play with them until the secondary bumps are gone. $\endgroup$ Dec 28, 2015 at 2:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .