2
$\begingroup$

My particle system is partly above the mesh and not distributed all over the mesh.

Particles system

enter image description here

Particle system settings top-bottom

enter image description here

enter image description here

Emitters' origins and location

enter image description here

How do I prevent the particles from going off the surface, but stay on the top of the mesh?

p.s: I weight painted the parts of the surface I want to emit my objects and added this vertex group to the density of the particle system

*EDIT: By setting the Normal value to 0 helps not so much, though it does make it slightly better with distribution.But the majority is still not in the right place.

**EDIT: It Actually seems like the children are the objects floating above and below, when I disable children all the objects are in the right place

enter image description here

Is there anything wrong with my children properties, that is causing them to be displaced above and below the object?

$\endgroup$
  • $\begingroup$ related: blender.stackexchange.com/questions/8918/… $\endgroup$ – cegaton Dec 26 '15 at 15:10
  • 1
    $\begingroup$ In your particle settings, look at your value for Velocity > Emitter Geometry > Normal. By default it is set to 1, and this makes particles hover slightly above the emitter's surface in the direction of its face normal. This is often a good starting value for animated particles, but not ideal for still particles, which it looks like yours are. In your case you'll probably want it to be set at 0, or something very low if you want to raise the particles up just a little. $\endgroup$ – Mentalist Dec 26 '15 at 17:00
  • $\begingroup$ @Mentalist when I set the Normal value to 0, all my particles disapeared $\endgroup$ – Igor Tatarnikov Dec 27 '15 at 10:06
  • $\begingroup$ Have you tried applying Rotation and Scale to each object in your Pebble Group? Also - Set Normal Slightly above 0 (0.01) as a starting point. $\endgroup$ – Rick Riggs Mar 14 '16 at 18:06
  • $\begingroup$ Also for your weight paint, look at your mesh in the outliner, and drill down into your vertex groups, the correct group name to use for weight paint will be in here, just go into weight paint and see which one gets highlighted. Then use it in the Density Field. $\endgroup$ – Rick Riggs Mar 14 '16 at 18:13
3
$\begingroup$

I had a similar issue and found the origin point of the objects in my "DupliGroup" were not centered on the geometry, causing each object to move away from the Emitter surface. Fixing the origin points fixed the issue.

$\endgroup$
1
$\begingroup$

Try setting your "Initial Orientation" to "Velocity/Hair" under Rotation. You seem to have it as "None", that seems to create all the children on parallel planes. (Edit: "Normal" or "Normal Tangent" may also work.)

$\endgroup$
0
$\begingroup$

I had that problem with a very organic shaped object andit was fixed by selecting INTERPOLATED on Children option.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.